version 3.1.0 (03-2016) - OLD

Les dernières versions d'Agora-Project se trouvent ici !
N'hésitez pas à partager vos premières impressions ou suggestions de correctifs.
xech
Administrateur du site
Messages : 779
Inscription : 17 janv. 2008, 20:58

version 3.1.0 (03-2016) - OLD

Message par xech » 15 mars 2016, 11:44

Bonjour à tous !
Voici une nouvelle version avec quelques améliorations de plus :

- Nouveau script d'affichage des menus contextuels : meilleur positionnement en bordure de page et sur des petites résolutions
- Amélioration diverses d'ergonomie, notamment des modules Dashboard et Calendar
- Amélioration de la confirmation de fermeture des iframes d'édition d'objet
- Correction de l'enregistrement des preferences des invités (exple : affichage des agendas)
- Optimisations diverses

à bientôt
Xech


PROCEDURE DE MISE A JOUR (version 2.0 ou plus récente) :
- Vérifier que le serveur possède une version PHP 5.4 ou plus récente
- Si besoin, vérifier que la mise à jour se fait sur une version standard d'Agora-Project, et non une version customisée/modifiée.
- Via le module d'administration de votre espace, cliquer sur « Sauvegarder la base de données et les fichiers » et vérifier l’intégrité du fichier téléchargé. Cette sauvegarde permet un retour en arrière en cas de difficulté.
- Télécharger le fichier "MISE-A-JOUR_agora-project.zip" ci-joint et décompresser l'archive sur votre poste
- Aller dans le répertoire du serveur web, à l'emplacement d'Agora-Project V2 (via un client Ftp si vous avez un hébergement mutualisé)
- Enlever les fichiers et dossiers de l'ancien Agora-Project : sauf le dossier "stock_fichiers" ou le dossier "DATAS" !
- Ajouter le contenu suivant de l'archive Zip : le dossier "app" puis le fichier "index.php"
- si besoin, donner un droit en Lecture+Ecriture+Exécution aux nouveaux dossiers et fichiers, et appliquer aux sous-dossiers ("chmod 775 -R")
- Avec votre navigateur, allez sur la page d'accueil de votre espace : la mise à jour est instantanée et un message apparaît pour confirmer l'installation. Note : le dossier "stock_fichiers" est automatiquement renommé en "DATAS".

PROCEDURE POUR UNE PREMIERE INSTALLATION :
- Vérifier que le serveur possède une version PHP 5.4 ou plus récente
- Télécharger le fichier "agora-project.zip" ci-joint et décompresser l'archive sur votre poste.
- Aller dans le répertoire du serveur web, ou sera installé Agora-Project V3 (via un client Ftp si vous avez un hébergement mutualisé).
- Ajouter le contenu suivant de l'archive Zip : "DATAS" + "app" + "index.php"
- si besoin, donner un droit en Lecture+Ecriture+Exécution aux nouveaux dossiers et fichiers, et appliquer aux sous-dossiers ("chmod 775 -R")
- Avec votre navigateur, allez sur la page d'accueil de votre espace : remplir le formulaire d'installation et valider. L'espace est prêt à l'emploi!
- PS : sur un espace perso Free, il faut créer un dossier "sessions" à la racine du site

.
Pièces jointes
MISE-A-JOUR_agora-project.zip
(8.01 Mio) Téléchargé 199 fois
agora-project.zip
(8.01 Mio) Téléchargé 179 fois

xech
Administrateur du site
Messages : 779
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.1.0 (03-2016)

Message par xech » 15 mars 2016, 11:58

@bvisciere
Parse error: syntax error, unexpected '[' in /var/www/vhosts/tours.fr/AGORA_CVL/app/Common/Req.php on line 65
à priori vous êtes sur une version de PHP qui n'interprète pas les déclarations simplifiées des variables de type "Array"
Pour info, quelle est la version PHP que vous utilisez?
merci

Fredlo14
Messages : 8
Inscription : 11 avr. 2012, 11:13

Re: Nouvelle version 3.1.0 (03-2016)

Message par Fredlo14 » 15 mars 2016, 12:00

Bonjour,
Merci pour cette nouvelle version.
J'ai migré de 2.17.5.1 vers 3.06 : Dans le paramétrage général bouton "Modifier" inactif. Impossible de modifier les réglages.
La MAJ de 3.0.6 à 3.1.0 n'a pas corrigé le problème.
Je travaille en local sous Wamp Php 5.5.12 MySql 5.6.17 Apache 2.4.9

Merci de votre réponse

Fredlo14
Messages : 8
Inscription : 11 avr. 2012, 11:13

Re: Nouvelle version 3.1.0 (03-2016)

Message par Fredlo14 » 15 mars 2016, 12:08

Oups... J'ai trouvé : en fait c'est la div pied de page qui gène l'activation du bouton au survol...

Désolé

bvisciere
Messages : 2
Inscription : 15 mars 2016, 10:48

Re: Nouvelle version 3.1.0 (03-2016)

Message par bvisciere » 15 mars 2016, 13:54

Merci beaucoup ! En effet c'est un PHP Version 5.3.3-7+squeeze29 (oups!). C'est bien dommage.
Hormis un upgrade de php, existe-t-il une autre solution qui me permettrait de bénéficier de la dernière version ?

corsaire
Messages : 22
Inscription : 27 sept. 2014, 10:00

Re: Nouvelle version 3.1.0 (03-2016)

Message par corsaire » 15 mars 2016, 20:11

Salut,

Elle me plait bien cette nouvelle version ! je vais continuer mes tests.

A+,
Stef

jeanmi34
Messages : 25
Inscription : 17 janv. 2012, 08:51

Re: Nouvelle version 3.1.0 (03-2016)

Message par jeanmi34 » 16 mars 2016, 08:56

Bonjour Xech,
Voici le message que j'ai lorsque je veux faire une mise à jour de 2.17.5 VERS 3.1.0.
Je suis sur un serveur mutualisé OVH - PHP 5.6
--------------------
internal error :

exception 'PDOException' with message 'SQLSTATE[23000]: Integrity constraint violation: 1062 ALTER TABLE causes auto_increment resequencing, resulting in duplicate entry '10' for key 'PRIMARY'' in /home/xxxxxx/www/ent2/app/Common/Db.php:39 Stack trace: #0 /home/xxxxxx/www/ent2/app/Common/Db.php(39): PDO->query('ALTER TABLE ap_...') #1 /home/xxxxxx/www/ent2/app/Common/DbUpdate.php(246): Db::query('ALTER TABLE ap_...') #2 /home/xxxxxx/www/ent2/app/Common/Ctrl.php(30): DbUpdate::lauchUpdate() #3 /home/xxxxxx/www/ent2/app/Common/Req.php(48): Ctrl::initCtrl() #4 /home/xxxxxx/www/ent2/index.php(3): Req->__construct() #5 {main}

[Back]
-------------------------------------------------------------
Merci pour toute aide
A+
Jeanmi

xech
Administrateur du site
Messages : 779
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.1.0 (03-2016)

Message par xech » 16 mars 2016, 09:29

jeanmi34 a écrit :exception 'PDOException' with message 'SQLSTATE[23000]: Integrity constraint violation: 1062 ALTER TABLE causes auto_increment resequencing, resulting in duplicate entry '10' for key 'PRIMARY''
A priori Mysql tente d'initialiser l'auto_Increment des champs "_id" mis à jour. Ce qui semble assez bizarre vu que les champs doivent déjà être en auto_Increment.. Serait-il possible d'avoir la version de Mysql ainsi qu'une extraction de la base de données (uniquement la structure) ?
cdlt, xech

jeanmi34
Messages : 25
Inscription : 17 janv. 2012, 08:51

Re: Nouvelle version 3.1.0 (03-2016)

Message par jeanmi34 » 16 mars 2016, 10:52

xech a écrit :
jeanmi34 a écrit :exception 'PDOException' with message 'SQLSTATE[23000]: Integrity constraint violation: 1062 ALTER TABLE causes auto_increment resequencing, resulting in duplicate entry '10' for key 'PRIMARY''
A priori Mysql tente d'initialiser l'auto_Increment des champs "_id" mis à jour. Ce qui semble assez bizarre vu que les champs doivent déjà être en auto_Increment.. Serait-il possible d'avoir la version de Mysql ainsi qu'une extraction de la base de données (uniquement la structure) ?
cdlt, xech
Bonjour Xech,
version PHP 5.6.17 / MySQL 5.5.46-0+deb7u1-log
en pièce jointe, la structure de ma base de données.
circosmtxbent_mysql_db.rar
(3.42 Kio) Téléchargé 156 fois
Merci pour ton aide !
Jeanmi

psendral
Messages : 56
Inscription : 19 janv. 2008, 14:06
Localisation : Castres - Tarn - France
Contact :

Fichiers word dans version 3.1.0

Message par psendral » 17 mars 2016, 09:40

Bonjour Xech,
Dans Firefox, il n'est pas possible d'ouvrir directement les documents Word présents dans le module Fichiers.
Ils s'enregistrent d'abord sur le disque dur.
Avec les fichiers Excel ou Pdf, le problème ne se pose pas : on peut au choix les ouvrir ou les enregistrer.
J'ai répété la même manip. avec IE et Chrome, et là tout se passe bien.
NB : ce petit problème existait déjà dans la version 3.0.6 ;)
Je continue à tester...
Philippe

mapauk73
Messages : 4
Inscription : 11 mars 2016, 10:36

Re: Nouvelle version 3.1.0 (03-2016)

Message par mapauk73 » 18 mars 2016, 09:03

Bonjour Xech,

Merci beaucoup pour ce superbe logiciel collaboratif. Je suis actuellement en phase de test pour une association.
J'ai un petit souci au niveau des import et export des cvs de l'annuaire.
Voila ce que j'ai dans mon cvs export
<b>Warning</b>: set_time_limit() has been disabled for security reasons in <b>/home/u313028448/public_html/app/Common/File.php</b> on line <b>176</b><br />

Pour la phase teste hébergement chez hostinger
PHP 7
Mysql 5.1

MAPA

mapauk73
Messages : 4
Inscription : 11 mars 2016, 10:36

Re: Nouvelle version 3.1.0 (03-2016)

Message par mapauk73 » 18 mars 2016, 11:05

mapauk73 a écrit :Bonjour Xech,

Merci beaucoup pour ce superbe logiciel collaboratif. Je suis actuellement en phase de test pour une association.
J'ai un petit souci au niveau des import et export des cvs de l'annuaire.
Voila ce que j'ai dans mon cvs export
<b>Warning</b>: set_time_limit() has been disabled for security reasons in <b>/home/u313028448/public_html/app/Common/File.php</b> on line <b>176</b><br />

Pour la phase teste hébergement chez hostinger
PHP 7
Mysql 5.1

Après recherche et plusieurs test je ne peux pas exporter l'annuaire de contact.
Les hébergeurs mutualisé comme hostinger, free ne permette pas la fonction set time limit() (Free.fr tourne en safe mode)
La seule chose que j'arrive a exporté se sont le titre des colonnes

Y a t il une solution ?

MAPA

corsaire
Messages : 22
Inscription : 27 sept. 2014, 10:00

Re: Nouvelle version 3.1.0 (03-2016)

Message par corsaire » 18 mars 2016, 15:07

Patience Mabauk73 !

Ici il n'y a personne 24H/24. Donc soit patient pour ta réponse.

A+,
Stef

xech
Administrateur du site
Messages : 779
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.1.0 (03-2016) - OLD

Message par xech » 20 mars 2016, 12:49

Bonjour à tous,
@mapauk73 : la dernière version 3.1.1 devrait corriger ce soucis de safemode
@jeanmi34 : le fichier .sql correspond à une version modifiée/customisée d'Agora-Project et non une version standard. La mise à jour n'étant pas prévu pour ce cas de figure, cela engendre donc des erreurs. Par curiosité, serait-il possible de savoir qui est à l'origine de ces modifications?

mapauk73
Messages : 4
Inscription : 11 mars 2016, 10:36

Re: Nouvelle version 3.1.0 (03-2016) - OLD

Message par mapauk73 » 20 mars 2016, 17:32

Bonjour,

J'avais déjà testé @set_time_limit(120)

Malgré la dernière mise à jour 3.1.1
Les seuls choses qui sont exportées vers le fichiers CVS sont les titres des colonnes.

Je continu à tester ce superbe logiciel

Merci

Mapauk

jeanmi34
Messages : 25
Inscription : 17 janv. 2012, 08:51

Re: Nouvelle version 3.1.0 (03-2016) - OLD

Message par jeanmi34 » 20 mars 2016, 23:28

xech a écrit :Bonjour à tous,
@jeanmi34 : le fichier .sql correspond à une version modifiée/customisée d'Agora-Project et non une version standard. La mise à jour n'étant pas prévu pour ce cas de figure, cela engendre donc des erreurs. Par curiosité, serait-il possible de savoir qui est à l'origine de ces modifications?
Bonjour Xech,
J'utilise Agora comme ENT pour des écoles et des enseignants et il y a quelques années, j'avais utilisé quelques modules de Cyrakuse : "messagerie" et "Faq" (et peut-être un autre module mais je ne me rappelle plus lequel). Cela doit expliquer les modifications apportées à la base de données.
Puisque je ne peux pas effectuer la mise à jour vers la version 3, je vais rester sur la 2.17.5.
Merci d'avoir pris du temps pour étudier la structure de ma base de données.
A+
Jeanmi

jeanmi34
Messages : 25
Inscription : 17 janv. 2012, 08:51

Re: Nouvelle version 3.1.0 (03-2016) - OLD

Message par jeanmi34 » 02 avr. 2016, 14:23

jeanmi34 a écrit :
xech a écrit :Bonjour à tous,
@jeanmi34 : le fichier .sql correspond à une version modifiée/customisée d'Agora-Project et non une version standard. La mise à jour n'étant pas prévu pour ce cas de figure...
Bonjour,
J'ai réussi à modifier dans la base les champs qui posaient problème et ainsi passer à la version 3.1.1
A+
Jeanmi34

Verrouillé