version 3.0.6 (03-2016) - OLD

Les dernières versions d'Agora-Project se trouvent ici !
N'hésitez pas à partager vos premières impressions ou suggestions de correctifs.
xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

version 3.0.6 (03-2016) - OLD

Message par xech » 25 janv. 2016, 18:28

Bonjour à tous !

Chose promise chose due, la nouvelle version 3.0 est arrivée et finalisée !
Une version renouvelée en profondeur, plus évolutive, fiable et rapide, avec une prochaine optimisation pour les appareils mobiles (tablette et smartphone). Le calcul des pages et l’affichage est en moyenne 2 fois plus rapide, et jusqu’à 5 fois plus rapide pour les arborescences de dossiers.
A noter qu’il est nécessaire d’utiliser PHP en version 5.4 minimum (POO oblige). Pensez donc à vérifier la compatibilité avec votre serveur web avant de lancer la mise à jour.

Principales améliorations :
- Nouvelle architecture entièrement en Programmation Orienté Objet : en moyenne 2 fois plus rapide
- Architecture MVC (Modèle-Vue-Contrôleur) pour un code plus clair, connexion MySQL basé sur la librairie PDO.
- Nouvelle visionneuse d’image et de vidéos : plus simple, rapide et mieux adaptée aux terminaux mobiles
- Nouveaux timePickers pour les sélections de dates et heures (module Calendar, Task, etc.)
- Accès direct aux éléments depuis les notifications mail (création/modification).
- Nouvelle version de TinyMce en v4.3.1 et PlUpload en v2.1.2
- Nouvelle version jQuery en v2.1.4 et jQuery UI en v1.11.4

Bien à vous
Xech


MAJ 3.0.1 :
Cette petite mise à niveau permettra de corriger le problème d'accès à l'install, rencontré sur certains hébergements.
Aussi, le problème d'affichage de la liste des utilisateurs sous Firefox a été corrigé
D'autre part, pour les versions antérieures à V.2.12 il faudra réinstaller la bdd de la sauvegarde (cf. procédure de mise à jour) et relancer la mise à jour : le cryptage des passwords n'a en effet pas pu être réalisé correctement.
Note: une sauvegarde de la base de données (.sql) est réalisée à chaque mise à jour, et stocké dans le répertoire /DATAS

MAJ 3.0.2 :
- Diverses optimisations javascript
- Correction de l'accès aux historiques de mail
- Correction de l'affichage des .pdf dans le gestionnaire de fichier sous Firefox
- Correction de l'affichage du menu des thèmes du forum
- Correction de la désactivation des raccourcis
- Correction de la période par défaut du dashboard
Merci à tous pour vos retours!

MAJ 3.0.3 :
- Correction du bug concernant les themes des forums sous PHP 5.4
- Correction de la mise à jour de vignettes d'image (non créées sous v2.17)
- Correction de l'installation sur les environnements MAC (AMPPS, XAMPP, etc)
- optimisations diverses

MAJ 3.0.4 :
- Amélioration de la gestion des affectations aux groupes dans le module Mail et Agenda
- Amélioration de la création des vignettes d'image et de leur orientation
- Ajout des descriptions pour le nouveaux fichiers uploadés
- optimisations diverses du code et de l'ergonomie générale
- optimisation du telechargement de très grosses archives
- optimisation du controle des types de fichiers uploadés
- Correction de l'affichage des dates si le module PHP "easter-date" n'a pas été pré-compilé
- correction sur la gestion des versions de fichiers
- Correction d'anciennes mises à jour (depuis v2.2)

MAJ 3.0.5
- Simplification des droits d'accès en écriture au dossier racine : désormais réduit à une simple option dans le paramétrage de l'espace
- Amélioration et simplification des certains menus : Barre principale de menu, Ajout de dossiers, etc
- Correction de mise à jour sur des bases de données multiples

MAJ 3.0.6
- Correction des imports de contacts dans le dossier racine
- correction de verif de l'extension Imagick sur les environnements Xampp


PROCEDURE DE MISE A JOUR (version 2.0 ou plus récente) :
- Vérifier que le serveur possède une version PHP 5.4 ou plus récente
- Si besoin, vérifier que la mise à jour se fait sur une version standard d'Agora-Project, et non une version customisée/modifiée.
- Via le module d'administration de votre espace, cliquer sur « Sauvegarder la base de données et les fichiers » et vérifier l’intégrité du fichier téléchargé. Cette sauvegarde permet un retour en arrière en cas de difficulté.
- Télécharger le fichier "MISE-A-JOUR_agora-project.zip" ci-joint et décompresser l'archive sur votre poste
- Aller dans le répertoire du serveur web, à l'emplacement d'Agora-Project V2 (via un client Ftp si vous avez un hébergement mutualisé)
- Enlever les fichiers et dossiers de l'ancien Agora-Project : sauf le dossier "stock_fichiers" ou le dossier "DATAS" !
- Ajouter le contenu suivant de l'archive Zip : le dossier "app" puis le fichier "index.php"
- si besoin, donner un droit en Lecture+Ecriture+Exécution aux nouveaux dossiers et fichiers, et appliquer aux sous-dossiers ("chmod 775 -R")
- Avec votre navigateur, allez sur la page d'accueil de votre espace : la mise à jour est instantanée et un message apparaît pour confirmer l'installation. Note : le dossier "stock_fichiers" est automatiquement renommé en "DATAS".

PROCEDURE POUR UNE PREMIERE INSTALLATION :
- Vérifier que le serveur possède une version PHP 5.4 ou plus récente
- Télécharger le fichier "agora-project.zip" ci-joint et décompresser l'archive sur votre poste.
- Aller dans le répertoire du serveur web, ou sera installé Agora-Project V3 (via un client Ftp si vous avez un hébergement mutualisé).
- Ajouter le contenu suivant de l'archive Zip : "DATAS" + "app" + "index.php"
- si besoin, donner un droit en Lecture+Ecriture+Exécution aux nouveaux dossiers et fichiers, et appliquer aux sous-dossiers ("chmod 775 -R")
- Avec votre navigateur, allez sur la page d'accueil de votre espace : remplir le formulaire d'installation et valider. L'espace est prêt à l'emploi!
- PS : sur un espace perso Free, il faut créer un dossier "sessions" à la racine du site
Pièces jointes
MISE-A-JOUR_agora-project.zip
(8.82 Mio) Téléchargé 482 fois
agora-project.zip
(8.83 Mio) Téléchargé 346 fois

pourquoipas
Messages : 5
Inscription : 27 janv. 2016, 10:16

Re: Nouvelle version 3.0 (01-2016)

Message par pourquoipas » 27 janv. 2016, 10:28

Bonjour,
Installation chez Free, PHP 5.6.8
Pas une mise à jour mais une nouvelle installation, j'ai l'erreur suivante :
Fatal error: Call to a member function query() on null in /var/www/........./agora/app/Common/Db.php on line 79
à noter que mes précédents essais avec la version 2.17.5.1 m'affichait la page d'install
une idée ?

psendral
Messages : 56
Inscription : 19 janv. 2008, 14:06
Localisation : Castres - Tarn - France
Contact :

Re: Nouvelle version 3.0 (01-2016)

Message par psendral » 27 janv. 2016, 17:59

Bonjour Xech,
Un premier retour d'expérience sur la nouvelle version :
La mise à jour de la version 2.17.5.1 vers la 3.0 s'est correctement passée.
Par contre, j'ai rencontré quelques anomalies de fonctionnement sous Firefox :
- les groupes d'utilisateurs n'apparaissent pas.
- la liste déroulante qui permet de sélectionner tous les utilisateurs ou seulement ceux d'un espace est inopérante.
Je pense d'ailleurs que les 2 problèmes sont liés.
Ce problème n'apparaît pas sous IE et Chrome où tout à l'air de bien fonctionner.
Cordialement.
Philippe
Dernière modification par psendral le 27 janv. 2016, 20:07, modifié 4 fois.

herve
Messages : 38
Inscription : 04 mai 2011, 17:15

Re: Nouvelle version 3.0 (01-2016)

Message par herve » 27 janv. 2016, 19:29

Bonjour;

La mise à jour à partir d'une version Agora-Project 2.17.1(PHP 5.6.15) n'a pas correctement fonctionné

A la tentative de connexion d'un utilisateur ( toto ) j’obtiens ce message, sous Firefox, Chrome .

Image

De plus quand je me connecte immédiatement après sur un espace public ( avec mot de passe ) je me retrouve sur le compte de l'utilisateur toto.


Hervé

prtice.seb
Messages : 42
Inscription : 22 juin 2009, 17:48
Contact :

Re: Nouvelle version 3.0 (01-2016)

Message par prtice.seb » 28 janv. 2016, 01:01

Pour la première fois j'ai un gros pb de mise à jour ! Mais en milieu scolaire ça flingue ton travail...ouïe...
J'ai uploadé la mise à jour, ensuite j'ai tout effacé puis remis, mais à chaque fois le module "Actualités" et/ou "Fichiers"" ne fonctionne pas bien. J'ai des résultats différents suivant l'Agora (2 dans 2 dossiers différents, sur 2 BDD différentes). Mais globalement le pb semble venir de l'affichage des modals.
agora3.JPG
agora3.JPG (28.51 Kio) Consulté 43219 fois
agora2.JPG
agora2.JPG (52.03 Kio) Consulté 43219 fois
agora1.JPG
agora1.JPG (43.01 Kio) Consulté 43219 fois
Merci d'avance de jeter un oeil.....urgent.....

ad.stb
Messages : 4
Inscription : 06 mai 2008, 07:55

Re: Nouvelle version 3.0 (01-2016)

Message par ad.stb » 28 janv. 2016, 08:40

Bonjour,
Je viens d'essayer d'installer la nouvelle version du logiciel via ftp.
Mais aaaaaaarg ! Lors de la connexion, j'ai un beau message d'erreur :
Fatal error: require_once(): Failed opening required 'app/Common/Req.php' (include_path='.:') in /var/www/vhosts/bts-nrc.le-net.org/httpdocs/index.php on line 2
J'ai réinstallé l'ancienne version, à moins que j'aie commis une erreur lors de l'installation ?
Bonne journée

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.0.1 (01-2016)

Message par xech » 28 janv. 2016, 20:32

MAJ 3.0.1 :
Cette petite mise à niveau permettra de corriger le problème d'accès à l'install, rencontré sur certains hébergements.
Aussi, le problème d'affichage de la liste des utilisateurs sous firefox a été corrigé
D'autre part, pour les versions antérieures à V.2.12 il faudra réinstaller la bdd de la sauvegarde (cf. procédure de mise à jour) et relancer la mise à jour : le cryptage des passwords n'a en effet pas pu être réalisé correctement.
Note: une sauvegarde de la base de données (.sql) est réalisée à chaque mise à jour, et stocké dans le répertoire /DATAS
En ce qui concerne les autres erreurs d'affichage, serait-il possible de donner plus de précisions : des erreurs javascript sont-elles affichées?
=>Clic droit sur la page =>cliquer sur "inspecter" =>onglet "console". Par ailleurs, le problème d'affichage est rencontré sur quels navigateurs, et quelle version?
Xech

herve
Messages : 38
Inscription : 04 mai 2011, 17:15

Re: Nouvelle version 3.0.1 (01-2016)

Message par herve » 28 janv. 2016, 23:41

Bonjour, bonsoir c'est selon :-)

Merci pour cette update ....... mais après essai de mise à jour d'une 2.17.5 vers la 3.0.1 voici le résultat d'une connexion

Image

c'est pas glop

Hervé

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.0.1 (01-2016)

Message par xech » 29 janv. 2016, 10:12

Bonjour Hervé,
Serait-il possible de savoir si cette version est d'origine ou s'il s'agit d'une version modifiée ?
En tout cas, il serait intéressant d'avoir plus de détails sur ce message d'erreur. Pour cela, il faudrait remplacer le fichier /common/Req.php par celui en pièce jointe (à décompresser bien sûr), réimporter la bdd 2.17.5 (dans le dossier /DATAS), puis relancer la mise à jour. Le message devrait alors s'afficher avec plus de détails, ce qui permettrait d'y voir un peu plus clair.
De plus, serait-il possible de m'envoyer la structure (en message perso) de la base de données d'avant la mise à jour (v2.17.5) et d'après la mise à jour, pour voir ce qui cloche? pour cela, allez dans phpmyadmin =>onglet "Exporter" =>option "Personnalisée" puis "Options spécifiques au format" et sélectionner "structure" au lieu de "structure et données".
Merci pour votre aide
Pièces jointes
Req.zip
(2.14 Kio) Téléchargé 315 fois

psendral
Messages : 56
Inscription : 19 janv. 2008, 14:06
Localisation : Castres - Tarn - France
Contact :

Re: Nouvelle version 3.0.1 (01-2016)

Message par psendral » 29 janv. 2016, 17:27

Bonjour Xech,
Je viens de passer de la version 3.0.0 à la version 3.0.1
J'utilise uniquement les modules actualités, fichiers et mailing-lists et tout fonctionne parfaitement.
Merci pour le correctif apporté à la liste des utilisateurs sous Firefox.
Pour info, voici ma config :
- hébergement mutualisé chez 1&1
- PHP 5.6.15
- MySQL 5.5.46-0
- testé avec Firefox 44 puis avec IE 11 puis avec Chrome 48
Cordialement
Philippe

PS. : dans ta procédure de mise à jour, tu devrais rajouter "ou le dossier DATAS" à la fin de la phrase qui se termine par "sauf le dossier "stock_fichiers"". ;)

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.0.1 (01-2016)

Message par xech » 29 janv. 2016, 18:27

psendral a écrit :"ou le dossier DATAS"
bien vu ;)

psendral
Messages : 56
Inscription : 19 janv. 2008, 14:06
Localisation : Castres - Tarn - France
Contact :

Re: Nouvelle version 3.0.1 (01-2016)

Message par psendral » 30 janv. 2016, 10:27

Bonjour Xech,
Je viens de détecter un message d'erreur lorsque je clique sur "Historique des e-mails envoyés" (voir pièce jointe).
Je précise que le mail est correctement envoyé mais que ce message apparaît quel que soit le navigateur utilisé (IE, Firefox ou Chrome).
Je continue mes investigations...
Philippe
Pièces jointes
e-mails_envoyes.jpg
e-mails_envoyes.jpg (13.44 Kio) Consulté 43069 fois

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.1 (01-2016)

Message par alainjean » 30 janv. 2016, 16:02

Bonjour Xech,
Merci pour cet immense travail ! Cette nouvelle version est effectivement beaucoup plus rapide. L'application est sur 1&1 mutualisé.
1 - comme le remarquait 'psendral', j'ai également la même erreur dans historique des emails envoyés : qu'il n'y ait ou non un email envoyé.
----- internal error :
exception 'Exception' with message 'File 'app/ModMail/vueMailHistory.php' unreachable' in /***/htdocs/agora/app/Common/Ctrl.php:337 Stack trace: #0 /****/htdocs/agora/app/Common/Ctrl.php(350): Ctrl::getVue('app/ModMail/vue...', Array) #1 /***/htdocs/agora/app/ModMail/CtrlMail.php(70): Ctrl::displayPage('vueMailHistory....', Array) #2 /***/htdocs/agora/app/Common/Req.php(49): CtrlMail::actionMailHistory() #3 /***/htdocs/agora/index.php(3): Req->__construct() #4 {main}-----
ennui : pour moi, les mails n'arrivent pas (plusieurs essais) alors que le message bulle affiche "email bien envoyé"
2 - Sur le gestionnaire de fichiers - pour l'affichage dans la page :
avec Chrome, les pdf s'affichent dans un popup. ok tout va bien.
mais avec Firefox... - (lien affiché, barre de menu : javascript:lightboxOpen('?ctrl=file&action=getFile&targetObjld=File-2&display=true&extension=.pdf') : c'est un nouvel onglet page blanche qui s'ouvre "about:blank".
- serait-il possible d'avoir pour les pdf un curseur loupe comme pour les images ?
3 - Serait-il possible dans l'éditeur et dans les événements de l'agenda, d'avoir un lien qui permette de sélectionner des fichiers à l'interne (déposés dans un dossier).
4 - Toujours Sur l'éditeur : comment voir le code source ? comment ajouter du HTML ? une bulle apparaît zone de texte riche : zone appuyer sur alt f9, etc... >> aucun effet
Merci beaucoup
Alain

ad.stb
Messages : 4
Inscription : 06 mai 2008, 07:55

Re: Nouvelle version 3.0.1 (01-2016)

Message par ad.stb » 30 janv. 2016, 17:12

Bonjour,
Suite aux réponses données ici même depuis mon dernier message, j'ai tenté une nouvelle mise à jour (depuis la version 2.17.3).
D'abord je me suis rendue compte de mon erreur : j'avais installé le contenu du dossier "app" alors qu'il fallait le mettre tel quel sur le serveur.
Bon. Donc pleine d'optimisme, j'ai fait la mise à jour :
- suppression de tous les fichiers sauf stock fichiers
- installation de "apps", puis index.php
Connexion... une belle page blanche.
J'ai testé cela sous Edge 25, Opera 34, et Firefox 44.

Je suis hébergée chez free-h, en hébergement mutualisé Je me suis connectée sur mon espage, pour vérifier la version php : il s'agit de la version php 5.4.45.
Par contre, lorsque je vais dans paramètrage général d'Agora, en haut j'ai PHP 5.3.29-1~dotdeb.0 . Le problème viendrait-il de là ?
Merci pour votre réponse
Bonne journée
Anouk

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.1 (01-2016)

Message par alainjean » 31 janv. 2016, 11:55

Bonjour Xech,
Après plusieurs essais,(version 3.0.1. origine non modifiée - installation neuve)
1 - je confirme, dans historique des emails envoyés : qu'il n'y ait ou non un email envoyé.
----- internal error : exception 'Exception' with message 'File 'app/ModMail/vueMailHistory.php' unreachable' in /***/htdocs/agora/app/Common/Ctrl.php:337 Stack trace: etc...
Par contre, l'envoi des mails se passe maintenant bien. Tout arrive aux destinataires.
2 - Je confirme : Sur le gestionnaire de fichiers - pour l'affichage dans la page d'un fichier en pdf; avec Firefox, on obtient une page blanche.
(avec Chrome, tout va bien.)
3 - Dans 'CtrlContact.php', il existe une fonction de création d'un utilisateur à partir d'un contact. Comment accéder à cette fonction car aucun bouton lien ne figure ni sur 'contact' ni sur 'utilisateur'.
Merci.
Alain

gandalf
Messages : 20
Inscription : 19 mai 2010, 23:53

Re: Nouvelle version 3.0.1 (01-2016)

Message par gandalf » 31 janv. 2016, 12:54

Bonjour, et encore bravo pour cette mise à jour !!

Y a t'il des modules complémentaires optionnels accessibles ici ou là, y a t'il des personnes qui à ta connaissance font ou projettent de se lancer dans cette aventure ?

gandalf
Messages : 20
Inscription : 19 mai 2010, 23:53

Re: Nouvelle version 3.0.1 (01-2016)

Message par gandalf » 31 janv. 2016, 13:22

Petit bug : quand on choisit d'enlever un dossier des raccourcis disponibles en haut d'écran, cette action est inopérante.

gandalf
Messages : 20
Inscription : 19 mai 2010, 23:53

Re: Nouvelle version 3.0.1 (01-2016)

Message par gandalf » 31 janv. 2016, 13:59

Pour continuer la liste de ce qui n'est a priori pas opérationnel, Il n'est pas possible de gérer les thèmes des forums.

prtice.seb
Messages : 42
Inscription : 22 juin 2009, 17:48
Contact :

Re: Nouvelle version 3.0.1 (01-2016)

Message par prtice.seb » 01 févr. 2016, 00:04

Bonjour,
j'ai les pb d'affichage sur des nouvelles versions ou des mises à jour, quel que soit le navigateur (Firefox, VIvendi, Opera en dernière version).
Pour les 2 premières images (aogra3 et agora 2), la console ne me signale rien.

Pour la fenêtre d'acu qui est vide, voilà ce que me donne la console Firefox:
"Failed to load: http://www.technologiescollege.fr/agora ... gin.min.js"

J'ai re-téléversé Agora, utilisé un autre navigateur, nettoyer les caches....pareil.

Merci de vite jeter un oeil car j'ai pété les agora en pleine séquence ENT pour mes élèves :o

prtice.seb
Messages : 42
Inscription : 22 juin 2009, 17:48
Contact :

Re: Nouvelle version 3.0.1 (01-2016)

Message par prtice.seb » 01 févr. 2016, 00:49

Problèmes de cache sur le serveur à priori....
Par FTP j'ai renommé le dossier agora5 en AgoraTruc et tout est nickel.
Navigateur portable téléchargé, dézippé, même problème quand le nom du dossier est le même que l'ancien. Donc un accélérateur chez mon hébergeur, je ne vois que ça.

AlainR
Messages : 88
Inscription : 28 sept. 2009, 08:40

Re: Nouvelle version 3.0.1 (01-2016)

Message par AlainR » 01 févr. 2016, 22:50

Bonsoir.

Merci pour cette version très intéressante.
2 bugs relevés et partiellement corrigés :

la liste des wallpaper ne se fait pas si aucun dossier wallpaper n'existe dans DATAS. En effet, les listes à choix de wallpapers restent vide, tant dans la config.générale que dans la confi. d'un espace, si le dossier DATAS/wallpaper n'est pas créé (il n'est pas renommé après migration d'une précédente version avec stock_fichiers)

L'autre bug est à l'installation si le mot de passe contient % cela provoque un problème de connexion à la BDD.

Je vais poursuivre mes découvertes à l'occasion.
Cdt.

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.0.1 (01-2016)

Message par xech » 03 févr. 2016, 12:15

Bonjour à tous. Pour cette version 3.0.2, quelques améliorations avec notamment :

- Diverses optimisations javascript
- Correction de l'accès aux historiques de mail
- Correction de l'affichage des .pdf dans le gestionnaire de fichier sous Firefox
- Correction de l'affichage du menu des thèmes du forum
- Correction de la désactivation des raccourcis
- Correction de la période par défaut du dashboard

Encore merci pour vos retours !
xech

lindes
Messages : 24
Inscription : 01 sept. 2010, 11:58

Re: Nouvelle version 3.0.2 (02-2016)

Message par lindes » 03 févr. 2016, 16:27

Bonjour,

Je rencontre un problème lors de la mise à jour depuis 2.17.5.1 avec :

UPDATE IN PROGRESS. please wait a few seconds

pendant des heures...

Une piste ?

Merci

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.2 (02-2016)

Message par alainjean » 03 févr. 2016, 22:31

Bonjour Xech,
Merci beaucoup pour les correctifs. L'optimisation de cette version est dans la ligne de mire !
Affichage sous Firefox impeccable, les mails fonctionnent, un vrai bonheur !
Mais comme on continue à fouiller... on trouve encore des p'ites choses...
- Dans le module agenda, dans un événement, la notification par mail affiche bien la liste des utilisateurs à cocher mais si on clique sur un groupe situé juste au-dessus, aucune sélection des utilisateur du groupe ne se produit sur la liste.
- Dans l'éditeur une bulle s'affiche "zone de texte riche, appuyez sur alt-F9 pour el menu... " - les commandes alt-F9 ou F-10 ou 0 restent sans effet.
C'est tout pour ce soir, bonne soirée et merci encore.
Alain

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.2 (02-2016)

Message par alainjean » 04 févr. 2016, 11:41

Bonjour Xech,
Encore une petite chose, mais beaucoup plus gênante :
En se déconnectant, la première page d'installation de la base s'est ré-affichée (au lieu de la page de login).
Ceci s'est produit sur la déconnexion d'un administrateur (et non de l'admin général).
Comment empêcher le retour à cette page d'install ? que faut-il supprimer svp ?
Merci
Alain

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.0.2 (02-2016)

Message par xech » 04 févr. 2016, 11:49

lindes a écrit :UPDATE IN PROGRESS. please wait a few seconds
Bonjour lindes, serait-il possible de connaitre la plateforme : linux ou windows (wamp, easyphp ou autre), la version de PHP, et si la version d'Agora-Project a été modifiée? Il serait intéressant d'avoir les détails des erreurs PHP et pour cela, refaire la mise à jour en laissant la procédure de mise à jour jusqu'à la fin : NE PAS RAFRAÎCHIR LA PAGE AVANT LA FIN DE LA MISE A JOUR ! Si possible, il faudrait aussi voir dans Logs d'erreurs Apache/PHP. Pour relancer la mise à jour, il faut penser à supprimer le fichier "DATA/currentUpdate.log", et récupérer au besoin la sauvegarde ".sql" de la base de données, dans le dossier /DATAS.
cdlt

alainjean a écrit :Dans le module agenda, dans un événement, la notification par mail affiche bien la liste des utilisateurs à cocher mais si on clique sur un groupe situé juste au-dessus, aucune sélection des utilisateur du groupe ne se produit sur la liste
Bonjour alainjean et merci pour ces retours. Dans l'édition d'un événement d'agenda, la sélection d'un groupe permet de sélectionner les agendas personnels des membres du groupe. Cela n'a pas de rapport avec les notifications par mail (d'ailleurs, ça n'est pas dans le même block de menu).
cdlt

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.2 (02-2016)

Message par alainjean » 04 févr. 2016, 15:33

Bonjour Xech,
- Module agenda : merci pour la précision ; effectivement, les groupes sont dans le bloc de sélection des agendas ; aucune action sur les mails.
Je m'étais mal expliqué : dans le module agenda, envoi d'un mail, la sélection des utilisateurs se fait un à un ; il serait bien que la sélection puisse aussi se faire par groupes comme pour le module mail.
- Module contacts : > modifier > photo : action changer : aucune action, l'ancienne photo reste. Pour remplacer la photo, il faut d'abord supprimer puis valider, puis revenir à la fiche, modifier et ajouter - Parfois, même la suppression ne fonctionne pas, la photo précédente est conservée (aléatoire).
Il est également impossible de supprimer un fichier joint.
Cordialement et merci
Alain

lindes
Messages : 24
Inscription : 01 sept. 2010, 11:58

Re: Nouvelle version 3.0.2 (02-2016)

Message par lindes » 04 févr. 2016, 17:05

Bonjour lindes, serait-il possible de connaitre la plateforme : linux ou windows (wamp, easyphp ou autre), la version de PHP, et si la version d'Agora-Project a été modifiée? Il serait intéressant d'avoir les détails des erreurs PHP et pour cela, refaire la mise à jour en laissant la procédure de mise à jour jusqu'à la fin : NE PAS RAFRAÎCHIR LA PAGE AVANT LA FIN DE LA MISE A JOUR ! Si possible, il faudrait aussi voir dans Logs d'erreurs Apache/PHP. Pour relancer la mise à jour, il faut penser à supprimer le fichier "DATA/currentUpdate.log", et récupérer au besoin la sauvegarde ".sql" de la base de données, dans le dossier /DATAS.
Merci pour le retour ! Agora tourne depuis des années sans problème sous Mac OS X, avec AMPPS, PHP 5.6.
J'ai relancé la mise à jour en supprimant currentUpdate.log sans résultat... la sauvegarde .sql dans DATAS a un poids de O octets...
Une erreur survient sporadiquement au cours des tentatives de mise à jour:

internal error :

exception 'PDOException' with message 'SQLSTATE[42S02]: Base table or view not found: 1146 Table 'agora_test.gt_utilisateur' doesn't exist' in /Applications/AMPPS/www/agora3/app/Common/Db.php:81 Stack trace: #0 /Applications/AMPPS/www/agora3/app/Common/Db.php(81): PDO->query('show columns fr...') #1 /Applications/AMPPS/www/agora3/app/Common/DbUpdateOld.php(38): Db::getCol('show columns fr...') #2 /Applications/AMPPS/www/agora3/app/Common/DbUpdateOld.php(70): DbUpdateOld::fieldExistOld('2.8.0', 'gt_utilisateur', 'agenda_plage_ho...', 'ALTER TABLE gt_...') #3 /Applications/AMPPS/www/agora3/app/Common/DbUpdate.php(72): DbUpdateOld::lauchUpdate() #4 /Applications/AMPPS/www/agora3/app/Common/Ctrl.php(30): DbUpdate::lauchUpdate() #5 /Applications/AMPPS/www/agora3/app/Common/Req.php(48): Ctrl::initCtrl() #6 /Applications/AMPPS/www/agora3/index.php(3): Req->__construct() #7 {main}

Par contre en installant une version "fraîche" de la 3, aucun problème d'install (sauf que je n'ai plus le contenu de la 2)
Merci encore. La version 2 tourne bien en // mais j'aimerais pouvoir passer à la 3 en conservant nos données.

Jerome442
Messages : 15
Inscription : 04 févr. 2016, 22:23

Re: Nouvelle version 3.0.2 (02-2016)

Message par Jerome442 » 04 févr. 2016, 22:31

Bonjour,

Je découvre Agora, étant relativement novice en php et complètement en mySQL.

J'ai créé un espace perso chez Free, activé ma base mySQL, mis le PHP en 5.6.8, copié la version 3.0.2 puis mis les droits 775 sur tous les fichiers.

Quand je lance monsite.free.fr/index.php, j'ai immédiatement le message d'erreur suivant :

Fatal error: Call to a member function query() on null in /var/www/sdb/b/f/monsite/app/ModOffline/CtrlOffline.php on line 172

en affichant phpinfo(), j'ai :
PHP Version 5.6.8
par contre, pour mySQL :
Version du serveur: 5.0.83

Vous avez une idée de ce que je dois faire ? Merci

PS : j'ai essayé d'installer la version précédente 2. et j'arrive bien sur la page me demandant le nom du serveur SQL, ... mais juste après j'ai un message d'erreur fatal également. A tout prendre je préfèrerai installer la version 3 :)

Jérôme

psendral
Messages : 56
Inscription : 19 janv. 2008, 14:06
Localisation : Castres - Tarn - France
Contact :

Re: Nouvelle version 3.0.2 (02-2016)

Message par psendral » 05 févr. 2016, 10:16

Bonjour,
De mémoire, chez Free, il faut créer un dossier "sessions" à la racine du site.
Cordialement.
Philippe

ad.stb
Messages : 4
Inscription : 06 mai 2008, 07:55

Re: Nouvelle version 3.0.2 (02-2016)

Message par ad.stb » 05 févr. 2016, 10:24

Après avoir contacté mon hébergeur, il a passé mon hébergement en php 5.4.45
Mise à jour, le fichier stock fichier est bien converti en DATAS, puis mise à jour du site, redémarrage du navigateur.
J'ai mon écran de connexion, puis une fois les identifiants entrés, j'obtiens ça :
Fatal error: Can't use function return value in write context in /var/www/vhosts/bts-nrc.le-net.org/httpdocs/app/ModForum/MdlForumSubject.php on line 88
Bonne journée

Fred48400
Messages : 3
Inscription : 05 févr. 2016, 13:18
Localisation : Florac
Contact :

Re: Nouvelle version 3.0.2 (02-2016)

Message par Fred48400 » 05 févr. 2016, 14:10

Bonjour, tout d'abord je tiens à vous féliciter pour cet outils qui convient parfaitement à la gestion de l'association dont je dépend.

Après avoir effectué la mise à jour en version 3.0.2, je constate de gros soucis qui m'empêchent de publier ou d'ajouter quoi que ce soit dans tous les modules. En effet après avoir validé la création d'une actualité, un sujet sur le forum ou encore un contact, j'ai une fenêtre blanche qui s'affiche avec comme seule possibilité de quitter. A aucun moment l'ajout n'est effectué.

Voici la capture d'écran :
Image

Suite à cela j'ai tenté d'effectuer une installation propre en réimportant ma base de données et même résultat.

J'ai le même soucis sous Firefox, Chrome et Edge.
Mon hébergeur est o2switch, PHP 5.5.29 et MYSQL 5.5.47-37.7

Merci de l'aide que vous pourrez m'apporter.
Fred

jepeto
Messages : 5
Inscription : 14 mai 2009, 14:37

Re: Nouvelle version 3.0.2 (02-2016)

Message par jepeto » 05 févr. 2016, 19:22

Bonjour à tous,

Il y a longtemps que j'utilise AGORA-PROJECT et je profite de l'occasion pour remercier tous ceux qui participent à ce projet qui nous rend de très grands services. Voilà, c'est maintenant que je deviens pénible, la version 3.0 upgradée sur 2.17.5 sans aucun problème, le passage à la version 3.0.2 m'affiche le message suivant immédiatement après connexion :

Code : Tout sélectionner

Fatal error: Can't use function return value in write context in /var/www/formplus.dev/app/ModForum/MdlForumSubject.php on line 88
Auriez-vous déjà rencontrer ce problème et sa solution s'il vous plaît ?
J'ai essayé de modifier les droits jusqu'à 775 sans effet.

Vous remerciant d'avnec,
JP

Jerome442
Messages : 15
Inscription : 04 févr. 2016, 22:23

Re: Nouvelle version 3.0.2 (02-2016)

Message par Jerome442 » 05 févr. 2016, 20:40

Alors en fait, je viens de découvrir que Free avait désactivé la fonction CHMOD
Du coup, impossible de changer les droits en 775 sur tous les fichiers, sauf si quelqu'un connait une autre possibilité ? en passant par un fichier PHP peut-être ?
Merci

Jerome442
Messages : 15
Inscription : 04 févr. 2016, 22:23

Re: Nouvelle version 3.0.2 (02-2016)

Message par Jerome442 » 05 févr. 2016, 23:54

Cela peut toujours vous servir, j'ai ouvert un hébergement gratuit chez hostinger.fr avec 2 Go d'espace disponible, et j'ai pu installer sans aucun problème la version 2 - pas la 3, il y a vait un message d'erreur POO, mais je pense que c'est à cause de la version php supportée.

Donc j'ai enfin réussi à installer et configurer mon espace Agora pour une association de danse, et en première impression c'est vraiment bien ! Merci

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.2 (02-2016)

Message par alainjean » 06 févr. 2016, 15:19

Bonjour Xech,
Je viens de mettre en évidence une erreur qui se produit systématiquement sur tous les 'dossier racine' du module fichiers > modifier et gérer les droits d'accès. Lors de la validation l'erreur suivante se produit :
Fatal error: Call to a member function folderPath() on a non-object in .../agora/app/Common/Ctrl.php on line 396
Cordialement,
Alain

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.2 (02-2016)

Message par alainjean » 06 févr. 2016, 17:33

Bonjour Xech,
Beau planté ! tout est bloqué :
Fatal error: Can't use function return value in write context in /.../agora/app/ModForum/MdlForumSubject.php on line 88
Cette erreur fait suite à l'activation du module forum sur un espace sur lequel il était désactivé avec déplacement de position.
Je vais essayé de réinjecter une base sauvegardée...
Alain

gandalf
Messages : 20
Inscription : 19 mai 2010, 23:53

Re: Nouvelle version 3.0.2 (02-2016)

Message par gandalf » 06 févr. 2016, 17:41

Bonjour,

je viens de déposer la 3.0.2 et là... c'est le drame !!

Il n'y a plus qu'une page blanche après m'être loggé.. :o

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.2 (02-2016)

Message par alainjean » 06 févr. 2016, 18:06

Bonjour Xech,
Suite au planté, j'ai réinjecté la base sauvegardée - ok tout va.
En tentant de remettre un forum sur un nouvel espace, pas de pb, par contre sur mon espace, ça plante !!
Fatal error: Can't use function return value in write context in /.../agora/app/ModForum/MdlForumSubject.php on line 88
Alain

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.2 (02-2016)

Message par alainjean » 06 févr. 2016, 18:53

Bonjour Xech,
Suite au planté, signalé ci-dessus :
Fatal error: Can't use function return value in write context in /.../agora/app/ModForum/MdlForumSubject.php on line 88
je suis revenu à l'ancienne version du code dans MdlForumSubject.php, à savoir :
public function getUrl($display=null)
....
if($this->inUndefinedTheme()) {return $urlBase."&_idTheme=undefinedTheme";}
elseif(!empty($this->_idTheme)) {return $urlBase."&_idTheme=".$this->_idTheme;}
else {return $urlBase;}
et cette fois, ça va... mais je ne tilte pas sur la source de l'erreur elle-même car le code est complexe.
A+
Alain

jlgenet
Messages : 8
Inscription : 16 sept. 2012, 21:28

Re: Nouvelle version 3.0.2 (02-2016)

Message par jlgenet » 07 févr. 2016, 10:58

Bonjour
comme beaucoup ici, MERCI pour cet outil qui m'est très utile auprès de mes élèves en technologie (collège),même si je le remplace par owncloud avec les plus grands.

Mise à jour effectuée vers 3.02 depuis 2.17 : OK sauf ...
Je dois désactiver les forums sino j'ai le message suivant : Fatal error: Can't use function return value in write context in /home/stmichel/www/ent/app/ModForum/MdlForumSubject.php on line 88

Je ne peut pas lire les images.
Videos : mp4 ok, flv : non ok

Impossible également de changer mon profil... demande de m'identifier avec mon courriel, que je réponde oui ou annuler cela ne fonctionne pas.

Ayant vu que mon PhP (OVH) était en 5.2 ! je l'ai passé en 5.6, résultat page blanche à la connexion.
Je vois ce qui se passe et je reviens !

Jean-Luc

Suite
J'ai essayé php 5.6 puis 4 et je suis revenu à 5.2 !!! Avec les problèmes décrits ci-dessus.
Dans les deux premiers cas, j'ai une page blanche après la connexion ! Mystère pour moi.
JL

Bonsoir (un jour plus tard)
J'ai modifié la moteur php : php au lieu de phpcgi
Le forum n'implique plu d'erreurs
Je ne peux toujours pas modifier mon profil.
Les fichiers textes, classeurs, videos flv, ne se teleharge pas correctement sur mon poste : ex de résultat à l'ouverture sur un odt : PK########6w�G^�2
JLuc
Dernière modification par jlgenet le 07 févr. 2016, 21:41, modifié 1 fois.

gandalf
Messages : 20
Inscription : 19 mai 2010, 23:53

Re: Nouvelle version 3.0.2 (02-2016)

Message par gandalf » 07 févr. 2016, 14:34

Bonjour,

je cherche le fichier dans lequel il faut que je paramètre l'envoi de mails (anciennement divers.inc.php dans la version 2.17.5) :?:

LeChi
Messages : 19
Inscription : 31 oct. 2008, 00:44

Re: Nouvelle version 3.0.2 (02-2016)

Message par LeChi » 08 févr. 2016, 11:46

Bonjour,

mise à jour (3.0.2) ratée depuis la version 2.17.2

d'abord, même message que Hervé : "Internal error [Back]"

Puis "UPDATE IN PROGRESS. please wait a few seconds", fixe depuis beaucoup plus que qq secondes... J'ai réinstallé la version 2.17.2 !

Je suis chez OVH, sur serveur mutualisé.
-> PHP 5.4.45 / MySQL 5.5.46

Chi

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.0.3 (02-2016)

Message par xech » 10 févr. 2016, 12:44

Bonjour à tous!

Une nouvelle version 3.0.3 vient de sortir, avec de nombreuses corrections et optimisations :
- Correction du bug concernant les thèmes des forums sous PHP 5.4
- Correction de la mise à jour de vignettes d'image (non créées sous v2.17)
- Correction de l'installation sur les environnements MAC (AMPPS, XAMPP, etc)
- optimisations diverses

Merci encore pour vos retours!
xech

studiocreeall
Messages : 2
Inscription : 10 févr. 2016, 17:42

Re: Nouvelle version 3.0.3 (02-2016)

Message par studiocreeall » 10 févr. 2016, 17:51

Salut à tous,

il y a peut-être un truc louche. En tout cas je n'avais jamais rencontré ce problème.

- Install fraiche de la V3 sur 2 Mac OSX avec apache et mysql installé dans le coeur.
=>> Page d'install OK, validation et création base de donnée OK
=>> redirection page login, échec du login ("Internal error") et si on re-tente en rafraichissant la page, boucle infini sur page login sans pop up erreur ou autre.

- Re install sur les même becanes avec apache / mySql depuis MAMP cette fois
=>> tout fonctionne comme prévu.

RAS sur les log apaches évidement.
php 5.6 sur les 2 Mac.

Si vous avez une piste... Je ne suis pas fan des programmes tiers (MAMP et al) quand le systeme lui-même propose les service. Et j'aimerais bien "comprendre" surtout.

Fred48400
Messages : 3
Inscription : 05 févr. 2016, 13:18
Localisation : Florac
Contact :

Re: Nouvelle version 3.0.3 (02-2016)

Message par Fred48400 » 10 févr. 2016, 18:43

Malheureusement toujours le même soucis même en 3.0.3... snif
Fred48400 a écrit :Bonjour, tout d'abord je tiens à vous féliciter pour cet outils qui convient parfaitement à la gestion de l'association dont je dépend.

Après avoir effectué la mise à jour en version 3.0.2, je constate de gros soucis qui m'empêchent de publier ou d'ajouter quoi que ce soit dans tous les modules. En effet après avoir validé la création d'une actualité, un sujet sur le forum ou encore un contact, j'ai une fenêtre blanche qui s'affiche avec comme seule possibilité de quitter. A aucun moment l'ajout n'est effectué.

Voici la capture d'écran :
Image

Suite à cela j'ai tenté d'effectuer une installation propre en réimportant ma base de données et même résultat.

J'ai le même soucis sous Firefox, Chrome et Edge.
Mon hébergeur est o2switch, PHP 5.5.29 et MYSQL 5.5.47-37.7

Merci de l'aide que vous pourrez m'apporter.
Fred
RESOLU :

Il suffisait de rajouter dans le fichier .htaccess :
#PHP 5.4 :
<FilesMatch \.php$>
SetHandler application/x-httpd-php54
</FilesMatch>
AddHandler application/x-httpd-php54 .php

Ne fonctionne pas avec d'autres versions pour moi.
Dernière modification par Fred48400 le 16 févr. 2016, 13:41, modifié 1 fois.

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.3 (02-2016)

Message par alainjean » 11 févr. 2016, 13:58

Bonjour xech,
Merci ! que dire de plus : merci pour tous ces correctifs apportés très rapidement avec cette version 3.0.3 !
A notre niveau d'utilisateur nous ne pouvons que mettre en évidence les quelques bugs qui se dissimulent (bien cachés, les bougres...) et que nous découvrons à l'usage. C'est notre très humble contribution.
Et paf ! en voici un petit nouveau... ;)
Dans le module Fichiers, après avoir ajouté une nouvelle version d'un fichier, la boite de dialogue montre les versions avec un bouton 'Supprimer'.
Sur Chrome, le bouton est sans action du tout et sur Firefox il est actif, la boite de dialogue de suppression s'ouvre mais au final rien n'est supprimé.
Encore merci !
Cordialement
Alain

psendral
Messages : 56
Inscription : 19 janv. 2008, 14:06
Localisation : Castres - Tarn - France
Contact :

Re: Nouvelle version 3.0.3 (02-2016)

Message par psendral » 12 févr. 2016, 16:03

Bonjour Xech,
Je teste actuellement la V.3.0.3 et dans le module Mailing List on peut sélectionner un groupe d'utilisateurs, mais on ne peut pas le "déselectionner".
De mémoire, il me semble que dans les versions 2, il y avait cette possibilité ainsi que celle d'inverser la sélection ; ce qui était bien pratique ;)
Je précise que les tests ont été faits sous IE, Firefox et Chrome.
Philippe

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.3 (02-2016)

Message par alainjean » 12 févr. 2016, 20:47

psendral a écrit :,
...dans le module Mailing List on peut sélectionner un groupe d'utilisateurs, mais on ne peut pas le "déselectionner".
Chez moi aussi, je confirme également, comportement identique ;)
cdlt
Alain

corsaire
Messages : 22
Inscription : 27 sept. 2014, 10:00

Re: Nouvelle version 3.0.3 (02-2016)

Message par corsaire » 16 févr. 2016, 23:04

Bonjour,

Voici quelques problèmes que j'ai avec la version 3.0.3 :

- Les vignettes des images ne se fait pas pour les fichiers de plus de 5 Mo apparemment.
- Le logo en bas de page ne prends plus le PNG, du moins il le transforme en JPEG, on perd la transparence.
- Lors d'un transfert d'un gros fichiers (test avec 200 Mo, 300 Mo), le téléchargement se fait, mais le fichier n’apparaît pas, dans le log c'est indiqué : offline et connexion.

- Notre serveur est configuré pour accepter les fichiers jusqu'à 1 Go, Agora nous indique que la taille maxi est de 1024 ko ! configurer avec 512 Mo c'est OK, mais on n'arrice pas à faire le transfert (voir plus haut).

Voilà pour mon retour d'expérience perso...
A+,
Stef

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.3 (02-2016)

Message par alainjean » 18 févr. 2016, 11:26

Bonjour Xech,
Je reviens pour les liens vers un fichier à partir de la page 'actualités'.
Un lien constitué ainsi :

Code : Tout sélectionner

index.php?ctrl=file&action=getFile&targetObjId=file-71&display=true&extension=.pdf
génère un fichier index.php et non un .pdf ce qui pose problème sous Windows, le fichier ne s'ouvre pas, WIndows ne sait pas le lire. Pas de pb avec Linux mais le fichier reste en php. Ce serait vraiment bien d'avoir une procédure qui ouvre un lien en .pdf. J'ai essayé d'injecter du code javascript selon les docs de tinymce mais celui-ci est systématiquement nettoyé.
Puis-je SVP obtenir une piste pour avoir un lien qui renvoie un fichier en .pdf ? merci beaucoup.
Alain

studiocreeall
Messages : 2
Inscription : 10 févr. 2016, 17:42

Re: Nouvelle version 3.0.3 (02-2016)

Message par studiocreeall » 23 févr. 2016, 13:45

studiocreeall a écrit :Salut à tous,

il y a peut-être un truc louche. En tout cas je n'avais jamais rencontré ce problème.

- Install fraiche de la V3 sur 2 Mac OSX avec apache et mysql installé dans le coeur.
=>> Page d'install OK, validation et création base de donnée OK
=>> redirection page login, échec du login ("Internal error") et si on re-tente en rafraichissant la page, boucle infini sur page login sans pop up erreur ou autre.

- Re install sur les même becanes avec apache / mySql depuis MAMP cette fois
=>> tout fonctionne comme prévu.

RAS sur les log apaches évidement.
php 5.6 sur les 2 Mac.
Problème résolu.
Cause : Mysql 5.7 nouveau standard dans les Globales par rapport aux anciennes versions, à savoir : sql_mode=only_full_group_by.
Supprimer ce mode résout le problème. Evidement le mieux sera de ré-écrire les requettes sql un de ces 4. Voir de gérer l'erreur et de transmettre un vrai message d'erreur.

corsaire
Messages : 22
Inscription : 27 sept. 2014, 10:00

Re: Nouvelle version 3.0.3 (02-2016)

Message par corsaire » 24 févr. 2016, 22:46

Bonjour,

Bon je suis repasser à la version 2 car j'ai des problèmes avec la V3.

Voici un récap des problèmes que j'ai avec la version 3.0.3 :

- Il y a un problème avec les agendas, les agendas créés en plus (je créé un agenda pour la réservation de salles) ne sont pas visible pour les invités. La case se décoche.
- Les vignettes des images ne se fait pas pour les fichiers de plus de 5 Mo apparemment.
- Le logo en bas de page ne prends plus le PNG, du moins il le transforme en JPEG, on perd la transparence.
- Lors d'un transfert d'un gros fichiers (test avec 200 Mo, 300 Mo), le téléchargement se fait, mais le fichier n’apparaît pas, dans le log c'est indiqué : offline et connexion.
- Notre serveur est configuré pour accepter les fichiers jusqu'à 1 Go, Agora nous indique que la taille maxi est de 1024 ko ! configurer avec 512 Mo c'est OK, mais on n'arrive pas à faire le transfert (voir plus haut).


A+,
Stef

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.0.4 (02-2016)

Message par xech » 29 févr. 2016, 19:57

Bonjour à tous, voici une nouvelle version 3.0.4 avec de nombreux correctifs et quelques petites améliorations :

- Amélioration de la gestion des affectations aux groupes dans le module Mail et Agenda
- Amélioration de la création des vignettes d'image et de leur orientation
- Ajout des descriptions pour le nouveaux fichiers uploadés
- optimisations diverses du code et de l'ergonomie générale
- optimisation du telechargement de très grosses archives
- optimisation du controle des types de fichiers uploadés
- Correction de l'affichage des dates si le module PHP "easter-date" n'a pas été pré-compilé
- correction sur la gestion des versions de fichiers
- Correction d'anciennes mises à jour (depuis v2.2)

Cordialement
Xech

psendral
Messages : 56
Inscription : 19 janv. 2008, 14:06
Localisation : Castres - Tarn - France
Contact :

Nouvelle version 3.0.4 (02-2016)

Message par psendral » 01 mars 2016, 17:25

Bonjour Xech,
Je viens de faire la M.A.J. de la version 3.0.3 vers la 3.0.4.
Merci pour les améliorations apportées, notamment au niveau du module "Mailing List" que j'utilise beaucoup.
La sélection ou dé-sélection des groupes destinataires du mail, fonctionne parfaitement.
Je continue mes investigations ;)
@+
Philippe

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.4 (02-2016)

Message par alainjean » 01 mars 2016, 23:00

Bonjour Xech,
Merci, merci pour ces optimisations, corrections, améliorations ! effectivement tout va beaucoup mieux avec cette version 3.0.4.
Comme Philippe, je continue mes plongées et pour le moment on respire bien... ;)
Je reviens pour demander une procédure pour placer un lien vers un fichier à l'interne, ce qui serait fort pratique. Peut-être dans une prochaine version ?
Cordialement
Alain

patrickB
Messages : 2
Inscription : 02 mars 2016, 12:22

Re: Nouvelle version 3.0.4 (02-2016)

Message par patrickB » 02 mars 2016, 13:07

Bonjour !
Tout semble bien fonctionner depuis la mise à jour en version 3 ! Cependant je ne reçois aucune notification du forum lors d'une création ou modification, bien que "me notifier par mail" soit activé dans le bandeau gauche (en rouge). En revanche, en utilisant la fonction de notification indépendante de chaque message, les mails partent bien, mais c'est lourd de devoir à chaque fois choisir les gens concernés...

cricketKiller
Messages : 1
Inscription : 02 mars 2016, 17:06

Re: Nouvelle version 3.0.4 (02-2016)

Message par cricketKiller » 02 mars 2016, 18:36

Bonjour,
je viens de faire la Mise à jour depuis 2.17.5.1 vers 3.0.4
à l'install j'ai le message suivant :

Code : Tout sélectionner

 internal error :

exception 'PDOException' with message 'SQLSTATE[42000]: Syntax error or access violation: 1091 Can't DROP 'comment_approved_date_gmt'; check that column/key exists' in /home/fxwebdev/www/gabare/app/Common/Db.php:39 Stack trace: #0 /home/fxwebdev/www/gabare/app/Common/Db.php(39): PDO->query('ALTER TABLE doc...') #1 /home/fxwebdev/www/gabare/app/Common/DbUpdate.php(226): Db::query('ALTER TABLE doc...') #2 /home/fxwebdev/www/gabare/app/Common/Ctrl.php(30): DbUpdate::lauchUpdate() #3 /home/fxwebdev/www/gabare/app/Common/Req.php(48): Ctrl::initCtrl() #4 /home/fxwebdev/www/gabare/index.php(3): Req->__construct() #5 {main}

[Back]
j'en déduis une erreur sur la BDD, dont la structure avant et après la MAJ est en pièces jointe.
a noté que je suis sur un serveur mutualisé chez OVH, avec plusieurs autre sites sur la même BDD.

merci pour votre aide, moi j'y comprend plus grand choses.
Pièces jointes
structure.zip
(1.84 Mio) Téléchargé 208 fois

IT JANSON
Messages : 6
Inscription : 18 févr. 2016, 08:49

Re: Nouvelle version 3.0.4 (02-2016)

Message par IT JANSON » 03 mars 2016, 10:07

Bonjour,

Tout d'abord, félicitations pour ce travail extra !

Je rencontre depuis mon passage en version 3 quelques petits soucis...

- dans le module FICHIERS, lorsque j'upload un fichier, il apparaît bien dans le répertoire, mais avec la mention suivante en en-tête de la page : "Notice: Undefined offset: 2 in E:\xampp\htdocs\intranet_test\app\Common\Req.php on line 90"
Et si il y a 10 fichiers dans le répertoire, c'est dix fois cette ligne qui apparaît, gâchant complètement la mise en page de la page...

- dans le module d'annuaire de contacts, si je me connecte en full admin, je sais faire tout ce que je veux, mais si je donne les droits en écriture à un usager, pour qu'il puisse par exemple mettre à jour les contacts, impossible pour lui de les sélectionner, ni de les déplacer d'un dossier à l'autre. Le petit bouton menu n’apparaît pas en haut à gauche de l'écran. Et je me vois mal le définir en admin de l'espace alors qu'il doit juste tenir les contact à jour.

- avec la version 2.17.5.1, que j'ai du remettre en attendant que soient résolus les soucis cités ci-dessus, lorsque mes utilisateurs tentent d'ouvrir notre intranet avec internet explorer, la boite de message "votre navigateur est trop ancien et ne prend pas en charge les standards html récent : il est vivement conseillé de le mettre à jour ou d'utiliser un autre navigateur" s'affiche systématiquement, et lorsqu'on a cliqué sur OK, on obtient juste un écran bleu sans login ni rien...
Le problème est que la majorité de mes users utilise internet explorer par défaut, et ne tient pas particulièrement à en changer
Qui plus est, iexplore n'est pas si ancien que cela, nous travaillons dans un environnement windows 2008R2 server avec internet explorer 10

Merci de vos éclaircissements sur ces questions et encore une fois félicitations pour le travail accompli

denis-37
Messages : 163
Inscription : 31 janv. 2011, 13:45
Localisation : Joue Les Tours - 37
Contact :

Re: Nouvelle version 3.0.4 (02-2016)

Message par denis-37 » 03 mars 2016, 17:25

Bonjour,
J'ai installé deux fois la version 3.0.4 une fois en test et une fois pour une utilisation finale sans souci. Par contre j'ai besoin de migrer une version 2.17.5 qui est sur PHP 5.4.33 / MySQL 5.1.73 et cela fait deux fois que j'essaie en ayant fait une copie complète pour tester et ça plante à chaque fois.
Pour me garantir des soucis j'avais mis les droits en 777 récursif sur tous les dossiers. A chaque fois le dossier stock est bien renommé en DATAS et je vois que le nom des tables a changé, mais ensuite voici ce que j'ai sur une page d'erreur.

The update generates errors : check the logs of Apache for details.
Come back to the previous version and try again the update if the issue is resolved.

La mise a jour a produit des erreurs : consultez les logs d'Apache pour plus de détails.
Revenez sur la version précédente puis relancez la mise à jour si le problème est résolu.

Dans les logs d'apache, voici ce que j'ai.
[Thu Mar 03 14:59:26 2016] [error] [client 1.2.3.4] File does not exist: /home/agora-test/www/favicon.ico
[Thu Mar 03 15:03:58 2016] [error] [client 1.2.2.4] File does not exist: /home/agora-test/www/commun, referer: http://agora-test.mondomaine.com/module_tableau_bord/

Je veux bien faire d'autres tests mais je n'ai aucune idée.
Quelqu'un aurait-il une idée car j'aimerai migrer mon association sur la version 3.0.4 car j'ai vraiment l'impression de constater une meilleure réception des mails du fait de l'identification de l'expéditeur.

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.0.4 (02-2016)

Message par xech » 03 mars 2016, 18:08

Bonjour à tous, pour répondre aux dernières interrogations :
@patrickB:
les notifications sont lancées à chaque création d'un nouveau message du forum, par un autre utilisateur. Mais à la création uniquement.
@cricketKiller:
Le problème vient surement du fait que phpBB et d'autres soft se trouvent sur la même base de données. Un correctif pour contourner se soucis sera donc présent sur la prochaine version v.3.0.5
@IT JANSON:
Il semble qu'une classe (et donc un fichier) soit absent : assurez-vous que toute l'application a été entièrement uploadé sur l'hébergement. Sinon, il serait intéressant de voir plus en détail les logs d'erreur d'Apache. D'autre part, assurez-vous que les droits d'accès de votre collègue soient bien en écriture sur le dossier source et le dossier destination des fichiers à déplacer. En ce qui concerne Internet explorer, normalement cela fonctionne bien à partir de la version 9. Cependant assurez-vous que vous utilisez bien la version 3.0.4 d'AP.
@denis-37
C'est bizarre que l'absence d'un simple fichier "favicon.ico" renvoie une erreur critique de php... il faudrait peut-être baisser le niveau de déclenchement des erreurs de PHP! Pour cela, il faut modifier la directive "error_reporting" du fichier de configuration de "php.ini" : mettre "E_ALL" pour un serveur de production (et penser à relancer le serveur Apache)

patrickB
Messages : 2
Inscription : 02 mars 2016, 12:22

Re: Nouvelle version 3.0.4 (02-2016)

Message par patrickB » 04 mars 2016, 10:37

xech a écrit :@patrickB:
Bonjour patrick, les notifications sont lancées à chaque création d'un nouveau message du forum, par un autre utilisateur. Mais à la création uniquement.
Merci pour votre réponse !
J'ai fait un essai: 1 seul utilisateur sur 2 (ayant activé la notification sur un forum) est notifié de l'ajout d'un sujet... Il doit y avoir un bug...
De plus, c'est bien dommage, dans mon ancienne version, les utilisateurs qui avaient activé la notification , recevaient un mail même en cas de mise à jour d'un sujet, ce qui était parfait pour l'utilisation que j'en fais... C'est possible de remettre cette fonction dans le future version ? Merci !!

Fredlo14
Messages : 8
Inscription : 11 avr. 2012, 11:13

Re: Nouvelle version 3.0.4 (02-2016)[Resolu]

Message par Fredlo14 » 04 mars 2016, 11:14

Bonjour,
J'ai migré sur mon ordi en local de la version 2.17.5.1 vers 3.04 et j'ai les mêmes erreurs que IT-JANSON en ouvrant les dossiers dans les modules Fichiers-dossiers : Notice: Undefined offset: in Req.php on line 90 pour chaque fichier listé
Je suis sous Wamp : Php 5.5.12 ; Mysql 5.6.17 ; Apache 2.4.9

Le problème ci-dessus est résolu avec la version 3.06 qui fonctionne parfaitement sur mon ordi en local...
Dernière modification par Fredlo14 le 14 mars 2016, 18:00, modifié 1 fois.

denis-37
Messages : 163
Inscription : 31 janv. 2011, 13:45
Localisation : Joue Les Tours - 37
Contact :

Re: Nouvelle version 3.0.4 (02-2016)

Message par denis-37 » 04 mars 2016, 13:26

denis-37 a écrit :Bonjour,
J'ai installé deux fois la version 3.0.4 une fois en test et une fois pour une utilisation finale sans souci. Par contre j'ai besoin de migrer une version 2.17.5 qui est sur PHP 5.4.33 / MySQL 5.1.73 et cela fait deux fois que j'essaie en ayant fait une copie complète pour tester et ça plante à chaque fois.
Pour me garantir des soucis j'avais mis les droits en 777 récursif sur tous les dossiers. A chaque fois le dossier stock est bien renommé en DATAS et je vois que le nom des tables a changé, mais ensuite voici ce que j'ai sur une page d'erreur.

The update generates errors : check the logs of Apache for details.
Come back to the previous version and try again the update if the issue is resolved.

La mise a jour a produit des erreurs : consultez les logs d'Apache pour plus de détails.
Revenez sur la version précédente puis relancez la mise à jour si le problème est résolu.

Dans les logs d'apache, voici ce que j'ai.
[Thu Mar 03 14:59:26 2016] [error] [client 1.2.3.4] File does not exist: /home/agora-test/www/favicon.ico
[Thu Mar 03 15:03:58 2016] [error] [client 1.2.2.4] File does not exist: /home/agora-test/www/commun, referer: http://agora-test.mondomaine.com/module_tableau_bord/

Je veux bien faire d'autres tests mais je n'ai aucune idée.
Quelqu'un aurait-il une idée car j'aimerai migrer mon association sur la version 3.0.4 car j'ai vraiment l'impression de constater une meilleure réception des mails du fait de l'identification de l'expéditeur.

Je rajoute un message d'erreur intermédiaire avant d'arriver à celui que je relate ci-dessus.
internal error :

exception 'PDOException' with message 'SQLSTATE[42000]: Syntax error or access violation: 1091 Can't DROP 'calendarid'; check that column/key exists' in /home/agora-test/www/app/Common/Db.php:39 Stack trace: #0 /home/agora-test/www/app/Common/Db.php(39): PDO->query('ALTER TABLE cal...') #1 /home/agora-test/www/app/Common/DbUpdate.php(226): Db::query('ALTER TABLE cal...') #2 /home/agora-test/www/app/Common/Ctrl.php(30): DbUpdate::lauchUpdate() #3 /home/agora-test/www/app/Common/Req.php(48): Ctrl::initCtrl() #4 /home/agora-test/www/index.php(3): Req->__construct() #5 {main}

denis-37
Messages : 163
Inscription : 31 janv. 2011, 13:45
Localisation : Joue Les Tours - 37
Contact :

Re: Nouvelle version 3.0.4 (02-2016)

Message par denis-37 » 04 mars 2016, 13:55

denis-37 a écrit :
denis-37 a écrit :Bonjour,
J'ai installé deux fois la version 3.0.4 une fois en test et une fois pour une utilisation finale sans souci. Par contre j'ai besoin de migrer une version 2.17.5 qui est sur PHP 5.4.33 / MySQL 5.1.73 et cela fait deux fois que j'essaie en ayant fait une copie complète pour tester et ça plante à chaque fois.
Pour me garantir des soucis j'avais mis les droits en 777 récursif sur tous les dossiers. A chaque fois le dossier stock est bien renommé en DATAS et je vois que le nom des tables a changé, mais ensuite voici ce que j'ai sur une page d'erreur.

The update generates errors : check the logs of Apache for details.
Come back to the previous version and try again the update if the issue is resolved.

La mise a jour a produit des erreurs : consultez les logs d'Apache pour plus de détails.
Revenez sur la version précédente puis relancez la mise à jour si le problème est résolu.

Dans les logs d'apache, voici ce que j'ai.
[Thu Mar 03 14:59:26 2016] [error] [client 1.2.3.4] File does not exist: /home/agora-test/www/favicon.ico
[Thu Mar 03 15:03:58 2016] [error] [client 1.2.2.4] File does not exist: /home/agora-test/www/commun, referer: http://agora-test.mondomaine.com/module_tableau_bord/

Je veux bien faire d'autres tests mais je n'ai aucune idée.
Quelqu'un aurait-il une idée car j'aimerai migrer mon association sur la version 3.0.4 car j'ai vraiment l'impression de constater une meilleure réception des mails du fait de l'identification de l'expéditeur.

Je rajoute un message d'erreur intermédiaire avant d'arriver à celui que je relate ci-dessus.
internal error :

exception 'PDOException' with message 'SQLSTATE[42000]: Syntax error or access violation: 1091 Can't DROP 'calendarid'; check that column/key exists' in /home/agora-test/www/app/Common/Db.php:39 Stack trace: #0 /home/agora-test/www/app/Common/Db.php(39): PDO->query('ALTER TABLE cal...') #1 /home/agora-test/www/app/Common/DbUpdate.php(226): Db::query('ALTER TABLE cal...') #2 /home/agora-test/www/app/Common/Ctrl.php(30): DbUpdate::lauchUpdate() #3 /home/agora-test/www/app/Common/Req.php(48): Ctrl::initCtrl() #4 /home/agora-test/www/index.php(3): Req->__construct() #5 {main}
En comparant une installation et une mise à jour je m'aperçois qu'il reste des tables de la version 2.17.5, je ne pense pas que cela soit normal, mais je ne comprends pas pourquoi, il s'agit de :
calendarobjects, calendars, groupmembers, gt_module, gt_tache_responsable, principals

emenglier
Messages : 3
Inscription : 04 mars 2016, 23:45

Re: Nouvelle version 3.0.4 (02-2016)

Message par emenglier » 04 mars 2016, 23:54

Bonjour, et merci pour cette application.
J'utilise actuellement la version 2.17.5.1, comme espace collaboratif d'une association.
Même si cette version fonctionne très bien, la curiosité et les améliorations de la version 3 (3.0.4) m'ont attirées, mais en suivant les instructions de mise à jour, je me retrouve avec une page blanche !
Mon erreur doit être grossière, mais je ne vois pas (infos. : PHP 5.6.14-0+deb8u1 / MySQL 5.5.44-0+deb8u1).
Merci pour les infos et conseils ...

Fredzefenec
Messages : 7
Inscription : 05 mars 2016, 02:40

Re: Nouvelle version 3.0.4 (02-2016)

Message par Fredzefenec » 05 mars 2016, 02:55

bonjour et merci pour cette application
je tente de l'installer pour une première fois sur un compte Hostinger, php 5.5, mysql 5.1.61
une fois le formulaire rempli, je valide et là...

Code : Tout sélectionner

internal error :
exception 'PDOException' with message 'SQLSTATE[42S02]: Base table or view not found: 1146 Table 'XX_agora.ap_userGroup' doesn't exist' in /home/XX/public_html/app/Common/Db.php:58 Stack trace: 
#0 /home/XXX/public_html/app/Common/Db.php(58): PDO->query('SELECT * FROM a...') 
#1 /home/XXX/public_html/app/ModUser/MdlUserGroup.php(64): Db::getObjTab('userGroup', 'SELECT * FROM a...') 
#2 /home/XXX/public_html/app/Common/Ctrl.php(69): MdlUserGroup::getGroups(Object(MdlSpace), Object(MdlUser)) 
#3 /home/XXX/public_html/app/Common/Req.php(48): Ctrl::initCtrl() 
#4 /home/XXX/public_html/index.php(3): Req->__construct() 
#5 {main}
sous phpmyadmin ma base s'est "peuplée" comme il faut visiblement
ou est mon erreur ?
Merci pour l'aide, j'ai hate d'essayer tout ça !
Frédéric

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.0.5 (03-2016)

Message par xech » 06 mars 2016, 19:56

Bonjour à tous! Pour cette mise à jour V3.0.5 :
- Simplification des droits d'accès en écriture au dossier racine : désormais réduit à une simple option dans le paramétrage de l'espace
- Amélioration et simplification des certains menus : Barre principale de menu, Ajout de dossiers, etc
- Correction de mise à jour sur des bases de données multiples

corsaire
Messages : 22
Inscription : 27 sept. 2014, 10:00

Re: Nouvelle version 3.0.5 (03-2016)

Message par corsaire » 06 mars 2016, 21:54

Bonjour,

Pas de correction pour ces problèmes avec la version 3.0.5 :

- Il y a un problème avec les agendas, les agendas créés en plus (je créé un agenda pour la réservation de salles) ne sont pas visible pour les invités sur l'espace. Ils apparaissent sur la gauche dans le menu, mais les cases se décochent et ils ne s'affichent pas.
- Lors d'un transfert d'un gros fichiers (test avec 200 Mo, 300 Mo), le téléchargement se fait, mais le fichier n’apparaît pas, dans le log c'est indiqué : offline et connexion.
- Notre serveur est configuré pour accepter les fichiers jusqu'à 1 Go, Agora nous indique que la taille maxi est de 1024 ko ! configurer avec 512 Mo c'est OK, mais on n'arrive pas à faire le transfert (voir plus haut).

A+,
Stef

Fredzefenec
Messages : 7
Inscription : 05 mars 2016, 02:40

Re: Nouvelle version 3.0.5 (03-2016)

Message par Fredzefenec » 07 mars 2016, 05:34

bonjour
idem, pas de correction à mon problème.
salutations
Frédéric

IT JANSON
Messages : 6
Inscription : 18 févr. 2016, 08:49

Re: Nouvelle version 3.0.5 (03-2016)

Message par IT JANSON » 07 mars 2016, 09:42

xech a écrit : @IT JANSON:
Il semble qu'une classe (et donc un fichier) soit absent : assurez-vous que toute l'application a été entièrement uploadé sur l'hébergement. Sinon, il serait intéressant de voir plus en détail les logs d'erreur d'Apache. D'autre part, assurez-vous que les droits d'accès de votre collègue soient bien en écriture sur le dossier source et le dossier destination des fichiers à déplacer. En ce qui concerne Internet explorer, normalement cela fonctionne bien à partir de la version 9. Cependant assurez-vous que vous utilisez bien la version 3.0.4 d'AP.
Bonjour,

Afin de tester correctement, j'ai réinstallé à partir de zéro tout le programme. Ainsi, pas de parasitage d'une version antérieure ou d'une option mal attribuée. J'ai intégré quelques données pour pouvoir faire mes tests.
Je travaille sous xampp, avec Agora-Project 3.0.5 - mis à jour : aujourd'hui PHP 5.5.15 MySQL 5.6.20

- Tout d'abord, Internet Explorer fonctionne correctement, c'est un soulagement pour mes utilisateurs Iexplore addicted :mrgreen:

- Ensuite, au niveau du traitement des contacts et de leur déplacement d'un dossier à l'autre, cela semble fonctionner, j'avais du mal paramétrer une option. En revanche, les contacts que j'ai importés à la racine du dossier en tant qu'admin général d'apparaissent pas à l'affichage (ils sont bien enregistrés dans la base de donnée), mais si j'ajoute manuellement un contact, il apparaît bien :?:
De plus, si je crée un dossier et que j'y importe de contacts, ils apparaissent bien dedans.
Cette observation est valable aussi pour le dossier des raccourcis.
Et si je créée un répertoire temp, que j'y importe les contacts/raccourcis voulus, puis que je déplace le contenu du répertoire vers le répertoire racine, alors ils apparaissent correctement :?: :?: :?:

- Et enfin, au niveau des fichiers dans les dossiers, malheureusement, pas d'amélioration, j'ai uploadé trois fichiers simples (pdf) et je me retrouve avec trois mentions d'erreur : Notice: Undefined offset: 2 in E:\xampp\htdocs\agora_project\app\Common\Req.php on line 90 :cry: Et je n'ai aucune erreur apache d'indiquée dans le log

- Je constate qu'il est impossible de modifier les droit d'accès d'un dossier racine comme c'était le cas dans la version 2.17, est-ce voulu ?

Je continue mes fouilles pour tenter de comprendre...
Merci de votre aide

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: Nouvelle version 3.0.6 (03-2016)

Message par xech » 07 mars 2016, 16:09

Bonjour à tous, voici une v3.0.6 avec quelques corrections spécifiques :
- Correction des imports de contacts dans le dossier racine
- Correction de verif de l'extension Imagick sur les environnements Xampp (erreur sur "Req.php")

@corsaire: il faudrait tester la config php.ini avec "post_max_size = 1024M" et "upload_max_filesize = 1024M". En effet il semble que php soit un peu tatillon dans le formatage de ce type de directives. En ce qui concerne les agendas cela fonctionne bien normalement si les droits ont bien été donnés aux invités.. plus de détails sur le problème rencontré à ce niveau?

emenglier
Messages : 3
Inscription : 04 mars 2016, 23:45

Re: Nouvelle version 3.0.4 (02-2016)

Message par emenglier » 07 mars 2016, 22:46

Fredzefenec a écrit :bonjour et merci pour cette application
je tente de l'installer pour une première fois sur un compte Hostinger, php 5.5, mysql 5.1.61
une fois le formulaire rempli, je valide et là...

Code : Tout sélectionner

internal error :
exception 'PDOException' with message 'SQLSTATE[42S02]: Base table or view not found: 1146 Table 'XX_agora.ap_userGroup' doesn't exist' in /home/XX/public_html/app/Common/Db.php:58 Stack trace: 
#0 /home/XXX/public_html/app/Common/Db.php(58): PDO->query('SELECT * FROM a...') 
#1 /home/XXX/public_html/app/ModUser/MdlUserGroup.php(64): Db::getObjTab('userGroup', 'SELECT * FROM a...') 
#2 /home/XXX/public_html/app/Common/Ctrl.php(69): MdlUserGroup::getGroups(Object(MdlSpace), Object(MdlUser)) 
#3 /home/XXX/public_html/app/Common/Req.php(48): Ctrl::initCtrl() 
#4 /home/XXX/public_html/index.php(3): Req->__construct() 
#5 {main}
sous phpmyadmin ma base s'est "peuplée" comme il faut visiblement
ou est mon erreur ?
Merci pour l'aide, j'ai hate d'essayer tout ça !
Frédéric
Bonjour,
j'ai également eu cette erreur chez l'hébergeur hostinger.
La table ap_userGroup n'avait pas été créée : Erreur MySQL "#1071 - Specified key was too long; max key length is 1000 bytes"
J'ai repris le script
CREATE TABLE ap_userGroup (
_id smallint(5) unsigned NOT NULL AUTO_INCREMENT,
title varchar(255),
_idSpace mediumint(8) unsigned,
_idUsers text,
dateCrea datetime DEFAULT NULL,
_idUser mediumint(8) unsigned DEFAULT NULL,
dateModif datetime DEFAULT NULL,
_idUserModif mediumint(8) unsigned DEFAULT NULL,
PRIMARY KEY (_id),
KEY `indexes` (_id,_idSpace,_idUsers(1000),_idUser)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
et j'ai diminué la valeur 1000 à 100 (sans autre raison que le fait que cette valeur passait, de toute façon c'est pour essayer d'avancer !)
Je vais maintenant continuer avec la version 3.0.6
Bonne soirée

Fredzefenec
Messages : 7
Inscription : 05 mars 2016, 02:40

Re: Nouvelle version 3.0.6 (03-2016)

Message par Fredzefenec » 08 mars 2016, 01:30

bonsoir
merci pour ce retour, par contre je ne sais pas où se trouve le fichier de construction de la base a modifier !

Code : Tout sélectionner

/app/common/Req.php
appelé par

Code : Tout sélectionner

index.php
ne contient pas cette construction il me semble...
dès que j'ai cette info je teste et je vous fais un retour
encore merci
Frédéric

IT JANSON
Messages : 6
Inscription : 18 févr. 2016, 08:49

Re: Nouvelle version 3.0.6 (03-2016)

Message par IT JANSON » 08 mars 2016, 09:36

xech a écrit :Bonjour à tous, voici une v3.0.6 avec quelques corrections spécifiques :
- Correction des imports de contacts dans le dossier racine
- Correction de verif de l'extension Imagick sur les environnements Xampp (erreur sur "Req.php")
Un travail remarquable ! Félicitations !

Je retrouve cependant un souci que je n'ai pas encore résolu :

Je délègue la gestion des contacts à un utilisateur. Pour ce faire, je lui attribue les droit en écriture complète sur les dossiers.
Et lorsqu'il se connecte, impossible pour lui de sélectionner des contacts, de les déplacer dans un autre dossier, etc. Il sait en les activant les modifier via le petit crayon, et c'est tout. Et aucun accès aux contacts à la racine du répertoire.
Dans la version 2.17, il y avait un petit bouton qui permettait de modifier les droits d'accès de tous les répertoires, dans la partie gauche de l'écran, avec l'arborescence, mais ce bouton a disparu. Je me demande si mon problème ne vient pas tout simplement de là : en ne pouvant pas modifier les droits en écriture sur le répertoire racine, ces droits ne sont pas répercutés...
Je joins le screenshot montrant de quoi je parle.

Merci encore de votre superbe travail !
Pièces jointes
2016-03-08_09h33_08.jpg
2016-03-08_09h33_08.jpg (48.03 Kio) Consulté 38080 fois
2016-03-08_09h32_57.jpg
2016-03-08_09h32_57.jpg (30.35 Kio) Consulté 38080 fois

jeanmi34
Messages : 25
Inscription : 17 janv. 2012, 08:51

Re: Nouvelle version 3.0.6 (03-2016)

Message par jeanmi34 » 09 mars 2016, 21:09

Bonjour,

J'étais sous Agora 2.17.5 et j'ai voulu faire la mise à jour vers 3.0.6 en suivant la procédure proposée par Xech.
Dès que la première connexion sur la page d'accueil de mon espace, j'ai le message :
------------------------------------------
internal error :

exception 'PDOException' with message 'SQLSTATE[42S02]: Base table or view not found: 1146 Table 'circosmtxbent.gt_forum_sujet' doesn't exist' in /home/circosmtxb/www/ent2/app/Common/Db.php:82 Stack trace: #0 /home/circosmtxb/www/ent2/app/Common/Db.php(82): PDO->query('show columns fr...') #1 /home/circosmtxb/www/ent2/app/Common/DbUpdateOld.php(38): Db::getCol('show columns fr...') #2 /home/circosmtxb/www/ent2/app/Common/DbUpdateOld.php(63): DbUpdateOld::fieldExistOld('2.8.0', 'gt_forum_sujet', 'users_notifier_...', 'ALTER TABLE gt_...') #3 /home/circosmtxb/www/ent2/app/Common/DbUpdate.php(76): DbUpdateOld::lauchUpdate() #4 /home/circosmtxb/www/ent2/app/Common/Ctrl.php(30): DbUpdate::lauchUpdate() #5 /home/circosmtxb/www/ent2/app/Common/Req.php(48): Ctrl::initCtrl() #6 /home/circosmtxb/www/ent2/index.php(3): Req->__construct() #7 {main}

[Back]
------------------------------------------------
Agora est installé sur serveur mutualisé OVH - php 5.5
Merci pour votre aide et conseils !
A bientôt
Jeanmi

Fredzefenec
Messages : 7
Inscription : 05 mars 2016, 02:40

Re: Nouvelle version 3.0.6 (03-2016)

Message par Fredzefenec » 10 mars 2016, 00:46

bonjour Jeanmi34
on dirait que tu as le même type de problème que moi, à savoir que lors de la construction de la base, des paramètres ne passent pas chez ton hébergeur...
j'attends sagement qu'on m'indique où se trouve le fichier générant cette base, de mon côté il semblerait que changer la valeur

Code : Tout sélectionner

KEY `indexes` (_id,_idSpace,_idUsers(1000),_idUser)
permette de résoudre le bazar.
salutations
Frédéric

alainjean
Messages : 20
Inscription : 30 janv. 2016, 09:43
Localisation : Besançon, Franche-Comté

Re: Nouvelle version 3.0.6 (03-2016)

Message par alainjean » 11 mars 2016, 10:56

Bonjour,
Pour moi, avec la 3.0.6 l'accès à la messagerie instantanée à disparu bien qu'elle soir activée et que le bouton gérer apparaisse.
Cordialement
Alain

denis-37
Messages : 163
Inscription : 31 janv. 2011, 13:45
Localisation : Joue Les Tours - 37
Contact :

Re: Nouvelle version 3.0.4 (02-2016)

Message par denis-37 » 11 mars 2016, 15:38

denis-37 a écrit :
denis-37 a écrit :
denis-37 a écrit :Bonjour,
J'ai installé deux fois la version 3.0.4 une fois en test et une fois pour une utilisation finale sans souci. Par contre j'ai besoin de migrer une version 2.17.5 qui est sur PHP 5.4.33 / MySQL 5.1.73 et cela fait deux fois que j'essaie en ayant fait une copie complète pour tester et ça plante à chaque fois.
Pour me garantir des soucis j'avais mis les droits en 777 récursif sur tous les dossiers. A chaque fois le dossier stock est bien renommé en DATAS et je vois que le nom des tables a changé, mais ensuite voici ce que j'ai sur une page d'erreur.

The update generates errors : check the logs of Apache for details.
Come back to the previous version and try again the update if the issue is resolved.

La mise a jour a produit des erreurs : consultez les logs d'Apache pour plus de détails.
Revenez sur la version précédente puis relancez la mise à jour si le problème est résolu.

Dans les logs d'apache, voici ce que j'ai.
[Thu Mar 03 14:59:26 2016] [error] [client 1.2.3.4] File does not exist: /home/agora-test/www/favicon.ico
[Thu Mar 03 15:03:58 2016] [error] [client 1.2.2.4] File does not exist: /home/agora-test/www/commun, referer: http://agora-test.mondomaine.com/module_tableau_bord/

Je veux bien faire d'autres tests mais je n'ai aucune idée.
Quelqu'un aurait-il une idée car j'aimerai migrer mon association sur la version 3.0.4 car j'ai vraiment l'impression de constater une meilleure réception des mails du fait de l'identification de l'expéditeur.

Je rajoute un message d'erreur intermédiaire avant d'arriver à celui que je relate ci-dessus.
internal error :

exception 'PDOException' with message 'SQLSTATE[42000]: Syntax error or access violation: 1091 Can't DROP 'calendarid'; check that column/key exists' in /home/agora-test/www/app/Common/Db.php:39 Stack trace: #0 /home/agora-test/www/app/Common/Db.php(39): PDO->query('ALTER TABLE cal...') #1 /home/agora-test/www/app/Common/DbUpdate.php(226): Db::query('ALTER TABLE cal...') #2 /home/agora-test/www/app/Common/Ctrl.php(30): DbUpdate::lauchUpdate() #3 /home/agora-test/www/app/Common/Req.php(48): Ctrl::initCtrl() #4 /home/agora-test/www/index.php(3): Req->__construct() #5 {main}
En comparant une installation et une mise à jour je m'aperçois qu'il reste des tables de la version 2.17.5, je ne pense pas que cela soit normal, mais je ne comprends pas pourquoi, il s'agit de :
calendarobjects, calendars, groupmembers, gt_module, gt_tache_responsable, principals
Bonjour;
Je viens de supprimer les tables non préfixés gt : (calendarobjects, calendars, groupmembers,_responsable, principal) et la migration s'est bien passée, pour le moment je n'ai pas l'impression que cela ait un impact, cela doit être un reste de module annexe que j'ai installé et que je pensais avoir supprimé.

jeanmi34
Messages : 25
Inscription : 17 janv. 2012, 08:51

Re: Nouvelle version 3.0.6 (03-2016)

Message par jeanmi34 » 12 mars 2016, 16:34

bonjour,
Je viens de faire un nouvel essai sur un autre serveur. (Mise à jour de 2.17.5 vers 3.0.6 sur mutualisé OVH - php 5.6 ).
Voici le premier message d'erreur qui apparaît lors de la première connexion.

------------------------------------------------------
internal error :

exception 'PDOException' with message 'SQLSTATE[23000]: Integrity constraint violation: 1062 ALTER TABLE causes auto_increment resequencing, resulting in duplicate entry '10' for key 'PRIMARY'' in /var/www/xxxxx/ent2/app/Common/Db.php:39 Stack trace: #0 /var/www/xxxxx/ent2/app/Common/Db.php(39): PDO->query('ALTER TABLE ap_...') #1 /var/www/xxxxx/ent2/app/Common/DbUpdate.php(247): Db::query('ALTER TABLE ap_...') #2 /var/www/xxxxx/ent2/app/Common/Ctrl.php(30): DbUpdate::lauchUpdate() #3 /var/www/xxxxx/ent2/app/Common/Req.php(48): Ctrl::initCtrl() #4 /var/www/xxxxx/ent2/index.php(3): Req->__construct() #5 {main}
----------------------------------------------------------

Voici le deuxième message d'erreur (après avoir fait "back")


------------------------------------------
internal error :

exception 'PDOException' with message 'SQLSTATE[42S02]: Base table or view not found: 1146 La table 'xxxxx.gt_forum_sujet' n'existe pas' in /var/www/xxxxx/ent2/app/Common/Db.php:82 Stack trace: #0 /var/www/xxxxx/ent2/app/Common/Db.php(82): PDO->query('show columns fr...') #1 /var/www/xxxxx/ent2/app/Common/DbUpdateOld.php(38): Db::getCol('show columns fr...') #2 /var/www/xxxxx/ent2/app/Common/DbUpdateOld.php(63): DbUpdateOld::fieldExistOld('2.8.0', 'gt_forum_sujet', 'users_notifier_...', 'ALTER TABLE gt_...') #3 /var/www/xxxxx/ent2/app/Common/DbUpdate.php(76): DbUpdateOld::lauchUpdate() #4 /var/www/xxxxx/ent2/app/Common/Ctrl.php(30): DbUpdate::lauchUpdate() #5 /var/www/xxxxx/ent2/app/Common/Req.php(48): Ctrl::initCtrl() #6 /var/www/xxxxxk/ent2/index.php(3): Req->__construct() #7 {main}

[Back]
------------------------------------------------

Merci pour votre aide et conseils !
A bientôt
Jeanmi

corsaire
Messages : 22
Inscription : 27 sept. 2014, 10:00

Re: Nouvelle version 3.0.6 (03-2016)

Message par corsaire » 14 mars 2016, 16:27

xech a écrit : @corsaire: il faudrait tester la config php.ini avec "post_max_size = 1024M" et "upload_max_filesize = 1024M". En effet il semble que php soit un peu tatillon dans le formatage de ce type de directives. En ce qui concerne les agendas cela fonctionne bien normalement si les droits ont bien été donnés aux invités.. plus de détails sur le problème rencontré à ce niveau?
Pour le post-max_size, le max de mon hébergeur (O2switch) est limité à 128 Mo maximum, donc je ne peux aller plus loin.

Pour les agendas, je confirme : les droits sont données en lecture aux invités sur plusieurs agendas, mais seul le premier s'affiche au niveau du calendrier (ils apparaissent bien dans le menu de gauche, quand on coche tous les agendas et que l'on fait Afficher, l'écran affiche toujours le premier et décoche les autres dans le menu. Demo sur http://c-prod.net/extranet

A+,
Stef

bvisciere
Messages : 2
Inscription : 15 mars 2016, 10:48

Re: Nouvelle version 3.0.6 (03-2016)

Message par bvisciere » 15 mars 2016, 11:47

Bonjour,
Actuellement en version 2.17.5.1, j'ai téléchargé la version pour "MISE-A-JOUR_agora-project.zip" depuis ce forum.
Je pense avoir bien respecté la procédure mais dès le lancement de la page d'accueil j'obtiens le message suivant :
Parse error: syntax error, unexpected '[' in /var/www/vhosts/tours.fr/AGORA_CVL/app/Common/Req.php on line 65
J'ai regardé le fichier en question et pas d'erreur de syntaxe comme cela m'est pourtant indiqué.

Quelqu'un pourrait-il me venir en aide ?
Merci d'avance de votre aide ...

Verrouillé