version 2.17.5 (09-2015) - OLD

Les dernières versions d'Agora-Project se trouvent ici !
N'hésitez pas à partager vos premières impressions ou suggestions de correctifs.
xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

version 2.17.5 (09-2015) - OLD

Message par xech » 19 sept. 2015, 17:06

VERSION 2.17.5 (09-2015)

- Librairie PHPmailer pour l'envoi des mails (penser à utiliser SPF et DKIM pour l'authentification des mails)
- Option de désactivation des Logs d'événements ("Durée de conservation des Logs" à "0" jours)
- Correctifs mineurs sur les "timezones"

Bonne rentrée à tous!


POUR METTRE A JOUR LES VERSIONS 2+, SUIVEZ MÉTHODIQUEMENT LA PROCÉDURE SUIVANTE:

1 - Sauvegarder la base de données, via le module d'administration de l'Agora
2 - Sauvegarder les dossiers et fichiers de l'Agora sur le serveur FTP, pour revenir en arrière si besoin
3 - Télécharger la dernière version de "MISE-A-JOUR_agora-project.zip" et décompresser l'archive sur votre poste
4 - Supprimer les dossiers et fichiers de l'Agora sur le serveur FTP -> SAUF LE DOSSIER "stock_fichiers" !!
5 - Envoyer les dossiers et fichiers de la mise à jour sur le serveur FTP
6 - faire un " chmod 775 -R" (ou "chmod 755 -R") pour donner accès en Lecture / Écriture / Exécution aux dossiers et fichiers -> Attention à bien sélectionner l'option "Récursion dans les sous-dossiers" !
7 - A la fin de votre mise à jour, REDÉMARREZ VOTRE NAVIGATEUR, puis affichez la page d'accueil de votre Agora : dès lors, la base de données est mise à jour.

NOTE : Si des messages d'erreur s'affichent, relancer l'envoi des fichiers sur le serveur FTP (le transfert FTP ne s'est probablement pas déroulé correctement)
Pièces jointes
agora-project.zip
(5.66 Mio) Téléchargé 673 fois
MISE-A-JOUR_agora-project.zip
(5.65 Mio) Téléchargé 620 fois

stephanePM
Messages : 46
Inscription : 10 mars 2014, 18:37

Re: VERSION 2.17.5 (09-2015)

Message par stephanePM » 20 sept. 2015, 12:00

bonjour xech,

les Notifications par mail semble refonctionner avec cette mise à jour 8-)
genial.
merci

je reviendrai ici pour confirmer après quelques jours d'utilisation.

psendral
Messages : 56
Inscription : 19 janv. 2008, 14:06
Localisation : Castres - Tarn - France
Contact :

affichage

Message par psendral » 25 sept. 2015, 09:45

Bonjour,
Je viens de faire la dernière mise à jour et je rencontre un problème au niveau :
- de l'édition des évènements de l'agenda
- sur l'ajout de fichiers dans le module fichiers
- sur l'envoi d'un mail
L'affichage se fait en plein écran et lors de la validation je suis "éjecté" de l'application sans en être déconnecté.
Il semblerait que l'affichage sous forme de pop up ne fonctionne pas... (testé avec IE, Firefox et chrome).
Avez-vous une solution ?
Je gère 8 plateformes pour une CCI et je suis très ennuyé.
Merci de votre retour d'expérience.
Pour info, je suis chez 1&1 et ma version de PHP est la 5.5.28 / MySQL 5.1.73-log
Philippe

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: affichage

Message par xech » 26 sept. 2015, 09:11

Bonjour Philippe,
Bizarre comme comportement. Et avec un vidage du cache des navigateurs ça ne change rien?
Aussi, est-ce que des erreurs apparaissent dans l'inspecteur de Chrome ou Firefox?
Exemple pour Chrome : clic droit sur la page + "inspecter l’élément" + onglet "console" + recharger la page.
D'ailleurs serait-il possible d'avoir des captures d'écran pour plus de détails?
Pour info, des tests ont été fait sur wamp & linux Debian, avec PHP 5.1 & 5.5 (la version de MySql importe peu dans ce cas de figure)
Xech

psendral a écrit :Bonjour,
Je viens de faire la dernière mise à jour et je rencontre un problème au niveau :
- de l'édition des évènements de l'agenda
- sur l'ajout de fichiers dans le module fichiers
- sur l'envoi d'un mail
L'affichage se fait en plein écran et lors de la validation je suis "éjecté" de l'application sans en être déconnecté.
Il semblerait que l'affichage sous forme de pop up ne fonctionne pas... (testé avec IE, Firefox et chrome).
Avez-vous une solution ?
Je gère 8 plateformes pour une CCI et je suis très ennuyé.
Merci de votre retour d'expérience.
Pour info, je suis chez 1&1 et ma version de PHP est la 5.5.28 / MySQL 5.1.73-log
Philippe

psendral
Messages : 56
Inscription : 19 janv. 2008, 14:06
Localisation : Castres - Tarn - France
Contact :

Re: VERSION 2.17.5.1 (09-2015)

Message par psendral » 26 sept. 2015, 09:40

Bonjour Xech,
Merci pour la rapidité de ta réponse.
Malgré tes conseils, les symptômes sont les mêmes.
Lorsque je modifie un élément de l'agenda, je sors de l'application au moment de la validation.
Ci-joint une copie d'écran réalisée avec Chrome.
Au pire, puis-je revenir à mon ancienne version sans dommage ?
Philippe
Pièces jointes
chrome.jpg
chrome.jpg (113.49 Kio) Consulté 12450 fois

xech
Administrateur du site
Messages : 773
Inscription : 17 janv. 2008, 20:58

Re: VERSION 2.17.5.1 (09-2015)

Message par xech » 27 sept. 2015, 16:06

Bonjour,
il semble que dans votre cas, cela soit lié à un problème de session. Serai-il possible de tester avec le fichier "/include/global.inc.php" ? cf. zip joint. Sinon il est effectivement possible de revenir sans soucis sur la version 2.17.4
xech
Pièces jointes
global.inc.php.zip
(3.97 Kio) Téléchargé 257 fois

psendral
Messages : 56
Inscription : 19 janv. 2008, 14:06
Localisation : Castres - Tarn - France
Contact :

Re: VERSION 2.17.5.1 (09-2015)

Message par psendral » 27 sept. 2015, 18:03

Bonjour Xech,
Je viens de faire le test et le problème reste entier.
Je suis donc revenu à la précédente version d'agora-project, et tout fonctionne à nouveau ;)
Merci quand même pour ta réactivité.
Philippe

Mr.Glloq
Messages : 39
Inscription : 07 août 2011, 19:40

Re: VERSION 2.17.5.1 (09-2015)

Message par Mr.Glloq » 15 oct. 2015, 18:00

Problème de création de dossier dans gestionnaire de fichier en PHP 5.6.13
Fonctionne parfaitement en 5.5.30

Post ouvert a ce propos dans Trucs et astuces

https://www.agora-project.net/clavardag ... =8&t=21847

salinator
Messages : 3
Inscription : 21 août 2013, 19:01

Re: VERSION 2.17.5.1 (09-2015)

Message par salinator » 10 nov. 2015, 11:27

Bonjour,

Depuis que j'ai installé la dernière version, je ne parviens plus à envoyer des mails à partir de l'E-mail de l'agora. Réponse: votre mail n'a pas pu être envoyé. ;)

Patrick

Zykmu
Messages : 2
Inscription : 24 oct. 2013, 21:51

Re: VERSION 2.17.5.1 (09-2015)

Message par Zykmu » 29 nov. 2015, 14:01

Bonjour,

Depuis quelques temps l'envoi de mails devenait de plus en plus difficile dans le sens où one.com ne transfert pas les mails considérés comma spam et depuis quelques jours, tous le sont à cause du code même des mails...

Tests de niveau de spam effectués avec : http://spamcheck.postmarkapp.com/

sur le fichier divers.inc.php dans le dossier fonctions,
j'ai modifié :
reply-to en reply_with_to_cc
ceci fait baissé un peu le taux de spam des mails mais fait aussi disparaître la liste des destinataires
j'ai ajouté au header :
$headers .= "date: ".$tab_timezones." <".$tab_timezones.">\n" ;
j'ai une baisse aussi du taux de spam mais il reste un problème de format donc encore un peu de taux de spam...

Voici, le code source du mail après ces modifs :

Code : Tout sélectionner

Return-Path: <christophe@club-aquabulles.fr>
Delivered-To: <patrick@club-aquabulles.fr>
Received: from mx6.public.one.com ([10.246.18.26])
	by mail21.local.one.com (Dovecot) with LMTP id jVcXEhnwWlZ3mQAAEgUWBg
	for <patrick@club-aquabulles.fr>; Sun, 29 Nov 2015 12:33:28 +0000
X-HalOne-ID: 635971bd-9695-11e5-81be-b82a72d854f0
Received: from mail-out2.one.com (unknown [91.198.169.19])
	by mx6.public.one.com (Halon Mail Gateway) with ESMTP;
	Sun, 29 Nov 2015 12:33:26 +0000 (UTC)
Received: from localhost.localdomain (web269.local.one.com [10.246.74.15])
	by mail-out2.one.com (Postfix) with ESMTP id 80051180081;
	Sun, 29 Nov 2015 13:33:26 +0100 (CET)
Received: from 78.246.77.118 by www.club-aquabulles.fr via /agora/module_mail/index.php with HTTP; dim., 29 nov. 2015 12:33:26 +0000
To: 
Subject: with to cc
X-PHP-Originating-Script: 2095859:divers.inc.php
From: Christophe <christophe@club-aquabulles.fr>
REPLYTO_WITH_TO_CC: Christophe <christophe@club-aquabulles.fr>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="-----=1451720015565af0965dfb3"
date:  <>

-------=1451720015565af0965dfb3
Content-Type: text/html; charset=UTF-8

<html>
<head>
<date>
</date>
<title>
</title>
</head>
<body>
Envoyé par Christophe (Aquabulles) :<br><br><p>to_cc</p><br><br><a href="http://club-aquabulles.fr/agora/" target='_blank'>Club Aquabulles</a><br></body>
</html>



-------=1451720015565af0965dfb3--
et le retour des bads de ce code :
pts rule name description
---- ---------------------- --------------------------------------------------
-0.7 RCVD_IN_DNSWL_LOW RBL: Sender listed at http://www.dnswl.org/, low
trust
[91.198.169.19 listed in list.dnswl.org]
0.0 URIBL_BLOCKED ADMINISTRATOR NOTICE: The query to URIBL was blocked.
See
http://wiki.apache.org/spamassassin/Dns ... nsbl-block
for more information.
[URIs: club-aquabulles.fr]
0.4 INVALID_DATE Invalid Date: header (not RFC 2822)
-0.0 SPF_HELO_PASS SPF: HELO matches SPF record
0.0 HTML_MESSAGE BODY: HTML included in message
1.1 MIME_HTML_ONLY BODY: Message only has text/html MIME parts
0.1 MISSING_MID Missing Message-Id: header
1.3 RDNS_NONE Delivered to internal network by a host with no rDNS

Que peut-on faire pour baisser ce taux ? notamment au niveau de la date, le mime, le message-id et le rdns none ?

Hébergement de notre site sur serveur one.com

N'hésitez pas à poser vos questions, j'y répondrai de mon mieux...

Merci.

Christophe

micha06301959
Messages : 1
Inscription : 01 déc. 2015, 12:05

Re: VERSION 2.17.5.1 (09-2015)

Message par micha06301959 » 01 déc. 2015, 12:11

bonjour à tous,

j'ai installé agora 2.17.2 sur xampp, et au passage bravo, c'est un excellent outil pour une petite institution comme celle où je travaille. Mais je n'arrive pas à réaliser la mise à jour... j'ai le message suivant Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\agorajp\fonctions\db.inc.php on line 80. Je suis sous windows7.

Merci de vos réponses et de votre aide

Antipodes
Messages : 17
Inscription : 10 mars 2009, 11:21

Re: affichage

Message par Antipodes » 05 janv. 2016, 10:04

Bonjour à tous,

En premier lieu une excellente année à toute l'équipe et utilisateurs d'Agora !
Je reviens sur ce post car j'ai pu constater les mêmes symptômes que Philippe. Mais pas à tous les coup...
En grattant un peu, je me suis rendu compte que :
- si j'arrive sur mon agora en passant par mon site principal et en ouvrant agora dans un "blank", les pop-up s'ouvrent en pleine page et donc le site se ferme à la validation (comme expliqué par Philippe).
- si j'arrive sur agora directement (ou en modifiant mon lien pour l'ouvrir dans la même fenêtre), les pop-up s'ouvrent normalement.

Pour résoudre mon problème j'ai donc modifié le lien proposé dans un menu de mon site, mais j'aimais bien l'idée de garder le site ouvert dans un onglet et d'ouvrir Agora dans un nouvel onglet...comme ça quand l'utilisateur ferme Agora, il retombe sur mon site...

Une solution simple possible ?

Marc
psendral a écrit :Bonjour,
Je viens de faire la dernière mise à jour et je rencontre un problème au niveau :
- de l'édition des évènements de l'agenda
- sur l'ajout de fichiers dans le module fichiers
- sur l'envoi d'un mail
L'affichage se fait en plein écran et lors de la validation je suis "éjecté" de l'application sans en être déconnecté.
Il semblerait que l'affichage sous forme de pop up ne fonctionne pas... (testé avec IE, Firefox et chrome).
Avez-vous une solution ?
Je gère 8 plateformes pour une CCI et je suis très ennuyé.
Merci de votre retour d'expérience.
Pour info, je suis chez 1&1 et ma version de PHP est la 5.5.28 / MySQL 5.1.73-log
Philippe

AlainR
Messages : 88
Inscription : 28 sept. 2009, 08:40

Re: affichage popup

Message par AlainR » 21 janv. 2016, 16:20

Bonjour.
Je confirme ce fonctionnement....aléatoire.
Et, tout à fait par hasard, pour des tests, j'ai réactivé mon agenda (dans profil) et le module Agenda (paramètres de l'espace) et les popups sont à nouveau fonctionnels.

Je viens de désactiver ET le module ET le paramètre du profil et pour l'instant les popups s'ouvrent toujours correctement. Même après déconnexion et reconnexion.

Je reviendrai poster après d'autres tests sur d'autres machines et après avoir vidé le cache du navigateur (Firefox, Linux).
Bien cordialement,
AlainR
Antipodes a écrit :Bonjour à tous,

En premier lieu une excellente année à toute l'équipe et utilisateurs d'Agora !
Je reviens sur ce post car j'ai pu constater les mêmes symptômes que Philippe. Mais pas à tous les coup...
En grattant un peu, je me suis rendu compte que :
- si j'arrive sur mon agora en passant par mon site principal et en ouvrant agora dans un "blank", les pop-up s'ouvrent en pleine page et donc le site se ferme à la validation (comme expliqué par Philippe).
- si j'arrive sur agora directement (ou en modifiant mon lien pour l'ouvrir dans la même fenêtre), les pop-up s'ouvrent normalement.

Pour résoudre mon problème j'ai donc modifié le lien proposé dans un menu de mon site, mais j'aimais bien l'idée de garder le site ouvert dans un onglet et d'ouvrir Agora dans un nouvel onglet...comme ça quand l'utilisateur ferme Agora, il retombe sur mon site...

Une solution simple possible ?

Marc
psendral a écrit :Bonjour,
Je viens de faire la dernière mise à jour et je rencontre un problème au niveau :
- de l'édition des évènements de l'agenda
- sur l'ajout de fichiers dans le module fichiers
- sur l'envoi d'un mail
L'affichage se fait en plein écran et lors de la validation je suis "éjecté" de l'application sans en être déconnecté.
Il semblerait que l'affichage sous forme de pop up ne fonctionne pas... (testé avec IE, Firefox et chrome).
Avez-vous une solution ?
Je gère 8 plateformes pour une CCI et je suis très ennuyé.
Merci de votre retour d'expérience.
Pour info, je suis chez 1&1 et ma version de PHP est la 5.5.28 / MySQL 5.1.73-log
Philippe

AlainR
Messages : 88
Inscription : 28 sept. 2009, 08:40

Re: VERSION 2.17.5 (09-2015)

Message par AlainR » 28 janv. 2016, 00:44

Hello.
Je confirme ce que j'ai écrit l'autre jour : agenda désactvé => popup dysfonctionne.
Je viens de réactiver l'agenda et un CTRL+F5 me permet d'avoir les popup correctement gérés.

Après désactivation du module agenda et CTRL+F5, c'est toujours fonctionnel.
Même après avoir redémarré le navigateur, vidé le cache, re-redémarré le navigateur.

@bientôt...
Cdt.

Verrouillé